[Snapshot Pro] Configure backups using Snapshot Pro and Amazone S3

Hi, hope you are having a great day!

I'm currently trying to create a situation where we create automated backup' s for all of our wp-websites using your plugin Snapshot. I want theme to be backuped every day with a max. of 7. Backups must be saved on an extern Amazone S3 solution. After 7 days i want the oldest backup to be removed etc. Can you tell me if this is possible? And how i can install this the correct way? In my opinion i've done that, but the backups doen't seem to get removed at this moment, leaving me with a lot off backups and storage on our S3.

Hope you can help me out!
Thanx!

Jens

  • viobru
    • Recruit

    Hi, Pim de Brock!

    Hope you are doing great and thanks for contacting us :slight_smile:

    Yes, it is possible to set snapshots to be created and stored as you need.
    To achieve this you should schedule snapshots to be created DAILY, set storage limit to keep 7 backups before removing older archives and MAKE SURE to CHECK the option to "Also clean remote repositories" during backup creation.
    Just to let you know, here you have a detailed explanation from my teammate Adam about how the "Also clean remote repositories" option does actually work: https://premium.wpmudev.org/forums/topic/snapshot-clean-remote-repositories#post-1328739

    Hope this helps :slight_smile:

    Have a nice day ahead and Happy New Year!

    Kind regards,
    Violeta

  • Pim de Brock
    • New Recruit

    Hi Violeta,

    Thanks for your reaction! Great!
    Unfortunately it doesn't seem to work that way, our maybe i've done something wrong.

    The configuration of the backup settings where already the same as in the screenshots, but the backups are not getting deleted :slight_frown:.

    Do you have any idea what could be the problem?

    Thanx!!

  • Pim de Brock
    • New Recruit

    Hi Kasia,

    Thanx for your reply!
    The plugin is updated to version: Versie: 3.2.0, i think thats the latest?
    For now i've removed all the backups on ore S3 storage and configured the amount of backups to two days, so we can test it without having to wait 7 days. So in a few days we will know if it works this way.

    Keep you posted!

  • Pim de Brock
    • New Recruit

    Hi Kasia,

    Unfortunately the update doesn't seem to work :slight_frown:. On 9 januari we've set the number of snapshots to keep at a remote destination to 2. As you can see in the screenshot of our S3 space, we are still facing the same problem :slight_frown:

    Hope you can help us out!

    • Pim de Brock
      • New Recruit

      Hi Jayman,

      Thanks for your reply and sorry for my delayed reaction.
      I've regranted you access to the website http://www.ptchr.nl. This is one of the websites where we are struggling with this issue. To be honest we have configured multiple website this way and we are facing the same error on all of them. But in my thought, if you can help us fixing the issue on our website http://www.ptchr.nl, we can fix the problem after that on the other ones ourself.

      As you can see the daily backup (pitcher_day) is still running (latest run 28 januari 2019 @ 03:39).

      - 'Keep a certain number of latest snapshots and remove the oldest' is checked.
      - ' Keep a local copy of a certain number of latest snapshots only' is checked.
      - 'Choose the number of snapshots to keep at the remote destination' is set on '2'.

      But when is take a look at the storage (see enclosed screenshot) not a single backup seems to be removed.

      Hope you can help us out!

  • Patrick Freitas
    • Staff

    Hi Pim de Brock

    Sorry for the delay here

    I configured on my end the S3 as the destination and needed some days for the tests. I copied your settings on my Snapshot installation, and I keep my backups being removed.

    Wouldn't you mind, please, send us some information and we can have a closer look?

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    - Site login URL:

    - WordPress admin username:
    - WordPress admin password:

    -S3 Credentials
    User
    Pass

    -Bucket URL:

    - FTP/SFTP credentials

    Host:
    Username:
    Password:
    Port:

    - cPanel credentials

    Host:
    Username:
    Password:

    - Folder path to the site in question:

    - Link back to this thread for reference

    - Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.
    Best Regards
    Patrick Freitas

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hey Pim de Brock !

    Thanks for reporting this, we've confirmed this as a bug and it will be fixed in a future update. I can't promise an ETA though for the time being for that but I can give you a workaround to help out for the time being!

    It seems that the issue is with the "Directory (optional)" setting in "Snapshots" that break the process of rotating through the backups, making them not getting removed from your server.

    What I can propose is to create 2 Destinations pointing to the same Amazon S3 but use a different directory from the Destination Settings instead leaving blank the "Snapshot" directory one since it will be handled by the destination itself.

    For example:
    Destination 1: site_backup/daily
    Destination 2: site_backup/monthly

    And you can set each Snapshot to each respective destination to use that folder. This should rotate the backups properly!

    Tell me if you need further help or information on fixing this and sorry for this inconvenience!

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.