[Snapshot Pro] cron error on scheduled Snapshot managed back up

I contacted last week to get Snapshot running. I thought we\'d fixed it but no backup since Feb13. Latest log gives multiple errors:

`[Cron][2018-02-19 12:08:13][Warning] Immediate hook misfired, kickstart backup processing

Doing a manual backup now appears to work, just the automatic that\'s affected. I\'ve enabled support access.
---
Wrote too soon. At about 40% the back up stopped and this error appeared on the screen.
http://cl.wonky.tech/3k0F0S0Q311W

FYI the host is GoDaddy. I've never used them before.

  • James Morris

    Hello Morgan,

    I hope you are well today.

    Internal Server Errors such as this generally point to a plugin conflict which triggers a 500 Internal Server Error.

    There's a couple troubleshooting steps I'd like you to try to see if we can narrow down the cause of this problem.

    First, could you please run a plugin conflict test to eliminate the possibility of a conflict with another plugin?

    Whenever you perform a plugin conflict test, it's always better to do so on a staging site. You can learn how to create a staging site here.

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new plugins folder
    * Move the plugin folder (ex: membership) you want to test from _plugins to plugins
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then save the file as a .txt file and upload it here as an attachment to your post.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

  • Morgan

    Thanks for your help. I turned off a number of plugins the site owner had left running. This appears to have cleared up the problem with Snapshot and also cut response times in half or better!

    Unfortunately, Automate has been failing on the backup stage before doing updates. Is this the same issue or something different? The latest email from Automate is below. Until now, it's worked almost flawlessly on other sites. This is the first time I'm using GoDaddy hosting and the first problem I've had with it.

    Morgan

    -------------------------
    G’day Morgan,

    Strewth maaaaaate, we ran Automate on naraiyer.com for ya! Here’s what we got up to:

    Feb 15, 2018 at 1:52am: Error when attempting full site backup
    Feb 16, 2018 at 10:45pm: Error when attempting full site backup
    Feb 17, 2018 at 3:55am: Error when attempting full site backup
    Feb 17, 2018 at 9:54am: Error when attempting full site backup
    Feb 17, 2018 at 3:57pm: Error when attempting full site backup
    Feb 17, 2018 at 9:55pm: Error when attempting full site backup
    Feb 17, 2018 at 9:55pm: Automate has been disabled due to multiple consecutive backup creation errors
    Feb 23, 2018 at 9:27am: Error when attempting full site backup
    Feb 23, 2018 at 4:17pm: Full site backup success
    Feb 23, 2018 at 4:43pm: Updated Ninja Forms from 3.2.13 to 3.2.14
    Feb 23, 2018 at 4:43pm: Updated WP All Import from 3.4.6 to 3.4.7
    Feb 23, 2018 at 4:43pm: Updated Primer from 1.4.2 to 1.8.2
    Feb 23, 2018 at 4:43pm: Updated Twenty Fourteen from 1.8 to 2.1
    After Automate we ran a Safe Upgrade check on your site:

    Uptime has pinged your site and it's UP, with no errors detected.

    We scanned your site for visual changes and the homepage is unchanged from it's pre-upgrade state:

  • James Morris

    Hello Morgan,

    This is rather strange considering that Automate uses Snapshot to perform the backups. In order to dig into this issue further for you, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.