Snapshot Pro Destination Customization

I'm getting started using Snapshot Pro to backup my multisite network. I have configured the local folder under Settings to C:\Snapshots\

I have created three snapshots (one for my root admin site, and one for each of two client sites in my network). In each snapshot settings, I have tried different settings in "Directory (Optional)", attempting to make each site store its snapshots in a subdirectory of C:\Snapshots\ but none are working.

Root Snapshot Optional Directory = [DEST_PATH]/[SITE_DOMAIN]
Client 1 Snapshot Optional Directory = /[DEST_PATH]/[SITE_DOMAIN]
Client 2 Snapshot Optional Directory = [DEST_PATH]/[SITE_DOMAIN]/

Regardless of what I put in the Optional Directory field, all 3 snapshots were created as .ZIP files in C:\Snapshots\ without creating any subdirectories.

Am I doing something wrong?

  • Vaughan
    • Support/SLS MockingJay

    Hi @Josef Cook,

    Hope you're well?

    I've just tested this on my own multisite & it worked fine.

    In my settings I have

    /home/vaughanm/snapshots

    Then when I created the snapshot I used the following in the optional directory field;

    /[DEST_PATH]/[SITE_DOMAIN]

    It then created the following;

    /home/vaughanm/snapshots/courses.mydomain.com/snapshot.zip
    /home/vaughanm/snapshots/jobs.mydomain.com/snapshot.zip

    and so on.

    Is this on local host server or a hosted server?

    Thanks

  • Josef Cook
    • Design Lord, Child of Thor

    This is on a local host. Windows Server 2012 R2, IIS 8, MySQL 5.5, PHP 5.4.24, WordPress 4.2.2.

    Perhaps it's because my path in settings is outside the site root? The documentation makes it sound like that is a supported config, but that's the only thing I can think of at the moment. However, there are no permissions issues, as it creates the ZIPs just fine. It just isn't creating subfolders as configured.

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    It should work fine outside the root as that's where mine is, my root is at;

    /home/vaughanm/public_html/

    I'm unsure why this isn't working on yours, the only difference I can see is that you are using windows IIS, whereas my server is Linux/Apache

    None of us here use IIS at all, so not sure we can test that quickly.

    Could you perhaps try it by using an address inside the root, just to test if it works ok then? at least we'll know for certain that being outside the root on IIS is the cause of this issue for you?

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.