Snapshot Pro fail at 88%

Every time I try to launch a backup on my multisite using Snapshot Pro, the completion bar proceeds until it reaches 88% where it remains stuck. Please help.

  • James Morris

    Hello Pablo Culebras

    I hope you are well today. Thank you for providing cPanel access so we could look into this issue further.

    First thing I notice is you have insufficient disk space available to perform backups. The directory containing the site you're trying to backup is using 1307.24MB of space. At present, your total account is at 2.27 GB / 3 GB (75.82%). Which means there's just no room for backups to be created. In order to use Snapshot, you will need to either upgrade your account to more space or do a significant cleanup to remove any unused files.

    Second, I noticed that your site is only configured with a PHP memory_limit of 256M. While this would likely be sufficient for a small, single instance WordPress site, this is not enough memory for running or backing up a Multisite Network. You will need to increase this to at least 512M.

    Provided your hosting provider supports PHP ini changes, you can use the following defines in wp-config.php to quickly increase the resources available to your Multisite Network without effecting other sites on the server. Add the following defines just before the line /* That's all, stop editing! Happy blogging. */

    // Performance Enhancements
    ini_set("memory_limit","1024M");
    // Increase WP Memory Limit
    define('WP_MEMORY_LIMIT', '1024M');

    Finally, I noticed you're running PHP 5.5.38. While everything *should* work fine on this version (Snapshot is verified to work with this version), this is a very old version of PHP and is not advisable for a production environment. There have not been any security or stability updates for PHP 5.5.38 in several years. The oldest, currently supported version of PHP is 5.6.30, and even that version is going end of live this year. It's advisable to upgrade to the PHP 7.1.x branch for security, stability and significantly improved performance.

    Once you take care of the above issues you should have no issues running Snapshots. However, if you still do, please ping us back here and we'll be more than happy to dig into this issue further for you! :slight_smile:

    Best regards,

    James Morris