Snapshot Pro- Getting error message

Hi all

I tried to hit the backup button to perform a manual backup, here is the error message i recieve after a couple of minutes...

Aw shucks, something went wrong :slight_frown: Instead of the beautiful response we expected, we got this:

Fatal error: Maximum execution time of 50 seconds exceeded in /customers/2/0/0/bilverdy.dk/httpd.www/wp-content/plugins/snapshot/lib/Snapshot/Helper/Zip/Archive.php on line 33

The key is in place...

Please advice

  • Nithin

    Hi Hamid,

    Hope you are doing good today. :slight_smile:

    Fatal error: Maximum execution time of 50 seconds exceeded in /customers/2/0/0/bilverdy.dk/httpd.www/wp-content/plugins/snapshot/lib/Snapshot/Helper/Zip/Archive.php on line 33

    I checked your system, and the above error states that you are having a lower limit for max_execution_time, and hence the plugin cannot progress.

    You'll have to increase the value for max_execution_time</strong, to increase the value, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    The above rules increases your websites memory to 521M, would recommend to add the above rules as it is in your php.ini file, as your website is running low in memory limit too.

    If you aren't able to increase your max_execution_time limit, would recommend you to get in touch with your host, in order to increase these values.

    Please check this link for more info, the article is about memory limit, however the steps mentioned are the same when it comes to increase max_execution_time:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Please let us know how that goes, have a nice weekend. :slight_smile:

    Best Regards,
    Nithin

  • Nithin

    Hi Hamid,

    As the error stated is a Fatal error, I'm afraid there isn't any other option to make that work. Please check with your host, and see whether they could at least increase the max_execution_time to 180. Only your host could provide you with a solution regarding this, as it's an issue specific to your server.

    Should the file be in the root or the wp-admin folder??

    Depending upon each host, the path where php.ini resides would differ, most common path where the file is added is in the root folder, but in some hosting provider it would be /wp-admin.

    Please do let us know how that goes with your host, have a nice day. :slight_smile:

    Best Regards,
    Nithin