Snapshot Pro Internal server error

Hi,

I am trying to make a backup of my site but every time it gets to Files: plugins it stops at 87% (13/15) and gives the following error:

"The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log."

Would love some help with this please.

Thank you so much.

  • Rupok

    Hi Jenny-Lyn, hope you had a wonderful day.

    The "Internal Error 500" is by nature one of the most undefined errors but in case of WordPress it's often related to memory issues. Therefore my suggestion here would be to start with increasing WP memory limit.

    In order to do this, please make sure that there's a line in your site's wp-config.php file:

    define('WP_MEMORY_LIMIT', '128M');

    The line should go anywhere below the opening "<?php" tag and above the "/* That's all, stop editing...." line. If it's already there and value is different than 128M (e.g. 96M or 256M) try rising it (e.g. 256M or 512M).

    Moreover, can you turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    Have a nice day. Cheers!
    Rupok

  • Ash

    Hello Jenny-Lyn

    This is the error you are getting in admin dashboard, but we need the error from error log. Please use ftp or cpanel file manager and go to wp-content folder, check if there is any file called debug.log. If so, download the file and open and check what is the error in there.

    Also, please ask your host to check server error log if you don't have access in there.

    Let us know about the errors. You can use http://pastebin.com if the file is too large.

    Have a good day!

    Cheers
    Ash

  • Jenny-Lyn

    OK this is what shows up in the file and it repeats quite a few times with the first 3 lines repeating and the fourth line a little different:

    [13-Aug-2016 18:10:06 UTC] PHP Notice: The called constructor method for WP_Widget in Widget_ContusVideosWidget_init is deprecated since version 4.3.0! Use

    __construct()
    instead. in /home/content/p3pnexwpnas03_data03/18/3133018/html/wp-includes/functions.php on line 3718
    [13-Aug-2016 18:10:06 UTC] PHP Notice: The called constructor method for WP_Widget in Widget_ContusVideoCategory_init is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home/content/p3pnexwpnas03_data03/18/3133018/html/wp-includes/functions.php on line 3718
    [13-Aug-2016 18:10:06 UTC] PHP Notice: The called constructor method for WP_Widget in Widget_ContusVideoSearch_init is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home/content/p3pnexwpnas03_data03/18/3133018/html/wp-includes/functions.php on line 3718
    [13-Aug-2016 18:10:06 UTC] PHP Notice: Undefined property: stdClass::$pages in /home/content/p3pnexwpnas03_data03/18/3133018/html/wp-content/plugins/search-engine-visibility/classes/plugin.php on line 128

    Thanks.

  • Kasia Swiderska

    Hello Jenny-Lyn,

    Those notices are not related to Snapshot or 500 internal server error. That is why Ash asked also for server log error.
    If you don't have access to server log please ask your hosting provider about it. Tell them you are trying to fix 500 internal server error and you need to know reason of it. They should be able to help with that or show us what is causing it.

    kind regards,
    Kasia

  • Nithin

    Hi Jenny-Lyn,

    Hope you are doing good today. :slight_smile:

    Also, please ask your host to check server error log if you don't have access in there.

    As mentioned above, Could you also share the server logs, you'll have to get in touch with your host, in order to get access to your server logs.

    Is there any specific reason that your host doesn't support the use of the plugin?

    You can either attach the log files in txt format, in your next reply, or you could share the file link using any of the cloud services like Dropbox.

    Kind Regards,
    Nithin

  • Nithin

    Hi Jenny-Lyn,

    Hope you are doing good today. :slight_smile:

    I contacted my host and there are no server logs.

    It's odd that there are no server logs, since I don't see you mention about plugin conflict test, could you please try disabling all the other plugin, and check whether your backup works? This should rule out whether any of the plugins are causing any conflicts.

    Could you also enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual.

    Kind Regards,
    Nithin

  • Nithin

    Hi Jenny-Lyn,

    Hope you are doing good today. :slight_smile:

    Thanks for granting support access, I could also notice that you haven't increased your memory limit, could you please try increasing your memory limit, and check whether it makes any difference.

    You can create a php.ini file inside your root directory, and add the following rules:

    upload_max_filesize = 1000M
    post_max_size = 2000M
    memory_limit = 3000M
    file_uploads = On

    These are example values, where memory limit is 3000M, you'll have to adjust these according to the limits offered by your host.

    For more info, check this article: https://premium.wpmudev.org/blog/increase-memory-limit/

    If you aren't able to increase the memory limits as mentioned above, you'll have to get in touch with your host in order to make this changes.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Jenny-Lyn,

    Hope you are doing good today. :slight_smile:

    Thanks for sharing the server log, unfortunately the debug logs doesn't help much, as there isn't any errors related to Snapshot. Could you please send us your credentials, so that we could give a closer look. Meanwhile could you please re-check your server logs, and see whether there are any errors generated?

    You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Jenny-Lyn,

    Hope you are doing good today. :slight_smile:

    In a Godaddy hosting, you'll have to make use of .user.ini file to increase the memory, instead of php.ini file. I have corrected the following, and have increased the memory limits.

    The issue seems to be with your files in plugins folder to be in large in size, and hence it ends up with internal error because of low memory limit.

    I have change the compression settings to PclZip, under Snapshots > Settings > Compression Library, and ran a test snapshot, and now it seems to work fine.

    Please check and confirm, and let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.