Snapshot Pro is not able to upload to Google Drive

Hey, seems that there is some problem with Google drive upload of snapshots. I have been having this error on multiple sites on different servers...

Connection seems to be established well, but the file transfer to Google Drive fails.

See the Status when the error happens:

An error occurred during the most recent upload attempt:
Error: Could not send file

Google_0814_Exception: Failed to start the resumable upload in /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php:290 Stack trace: #0 /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(138): Google_0814_Http_MediaFileUpload->getResumeUri() #1 /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(389): Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\x14\x00\x00\x00\x08\x00\x8A\xAC\xCFL\xE0...') #2 /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(262): SnapshotDestinationGoogleDrive->send_file('/data/web/virtu...') #3 /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/snapshot.php(7328): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/data/web/virtu...') #4 /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/snapshot.php(7226): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker)) #5 /data/web/virtuals/189360/virtual/www/wp-content/plugins/snapshot/snapshot.php(7546): WPMUDEVSnapshot->process_item_remote_files(1529091322) #6 /data/web/virtuals/189360/virtual/www/wp-includes/class-wp-hook.php(286): WPMUDEVSnapshot->snapshot_remote_file_cron_proc() #7 /data/web/virtuals/189360/virtual/www/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #8 /data/web/virtuals/189360/virtual/www/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #9 /data/web/virtuals/189360/virtual/www/wp-cron.php(126): do_action_ref_array('snapshot_remote...', Array) #10 {main}
:Failed to start the resumable upload
Further attempts to upload will continue to be made. However, you may want to investigate this issue to ensure that they are successful.

  • James Morris

    Hello Petr

    I've moved this ticket over into the Snapshot Pro support forum so we can investigate this issue further for you.

    I've got this setup configured on one of my production sites as well as a couple dev sites. I'm afraid I cannot replicate the issue.

    It's possible you may be having timeout issues. Would you please go to WPMU DEV Dashboard -> Support and click the System Info button. There you will find the value of your PHP max_execution_time. If this is < 180 then it's quite possible that the connection with Google is timing out. If it is lower than 180, please add the following to your wp-config.php file just before the /* That's all, stop editing! Happy blogging. */ line.

    @ini_set('max_execution_time', 180);

    Then retest to see if the issue persists.

    Also, with something mission critical such as backups, it's highly recommended that you disable WP_CRON and use system cron instead. The following primer on how to accomplish this should be most helpful.

    https://www.siteground.com/tutorials/wordpress/real-cron-job/

    Let us know how it goes!

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.