[Snapshot Pro] Large core.##### files being created on server

I believe this is related to Snapshot backups but after using the WPMU plugins I suddenly have many LARGE files on my server with names like core.10027, core.10329, etc. They are maxing out my storage space on my host and I'm looking for a way to prevent these from being made or at least limiting the amount of space they can take up.

  • Patrick Freitas

    Hi Seth

    How are you today?

    How are you creating the backups? You can use the Managed Backups option, this will delete the temporary file from the server after the backup upload on the cloud and you can manage it from the HUB - https://premium.wpmudev.org/hub/.

    However the .zip file size will depends of many facts as website size. You can find the backup storage on WordPress root folder/uploads/snapshot .

    Let me know if you need any further help for this.
    Best Regards.
    Patrick Freitas

  • Patrick Freitas

    Hi Seth

    How are you today?

    Wouldn't you mind please to send me the FTP information and I can have a closer look on the files.

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:
    Subject: "Attn: Patrick Freitas"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - If you use a different FTP port or SFTP
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Let me know when you send the information.
    Have a great day,
    Best Regards,
    Patrick Freitas

  • Patrick Freitas

    Hi Seth

    Thank you for the information, I had a closer look and we need to run some tests to figure out what is creating this dump data.

    First of all, I need that you remove all core.##### files.

    Then find the wp-config.php and increase the PHP memory.

    define( 'WP_MEMORY_LIMIT', '512M' );

    Please replace the line:

    define('WP_DEBUG', false);

    // Turn debugging on
    define('WP_DEBUG', true);
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    Login on WordPress dashboard > SnapShot Pro > Create a Snapshot and see if there is any new core.#### file.

    If so, by FTP access the WordPress Root Folder > wp-content and search for any debug.log, change it to Debug.txt and send as attach file.

    Also you can check this link, there are some relevant information: https://complete-concrete-concise.com/web-tools/wordpress-generating-core-dumps

    Let me know the results.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.