[Snapshot Pro] Managed Backup deactivating by itself each day

For the last two days, Managed Backup has deactivated itself each day. It had been running fine for several months. After the first incident, I clicked "Activate Managed Backups", then ran a manual backup. That was okay. The next day, when Automate! tried to run a backup, it failed because Managed Backups was deactivated again. This appears identical to this issue: https://premium.wpmudev.org/forums/topic/snapshot-pro-managed-backup-on-sites-turning-off-and-have-to-re-setup

  • Ash
    • WordPress Hacker

    Hello drew_mathers

    Sorry to know you are having this issue. This is unusual and should not happen.

    I have checked your automate log and it says: Backup start error: start_backup – Error starting remote backup: no key

    Would you please reset your snapshot keys and reconnect the managed backup? And please let us know if it disconnects again.

    Let us know how it goes. Have a nice day!

    Cheers,

    Ash

  • drew_mathers
    • Design Lord, Child of Thor

    Hi Ash,

    I reset the key as you instructed.

    This morning’s Automate! report shows two failed backup attempts and one success. The Snapshot log shows:

    [snapshot][2019-02-06 11:07:00][Warning] Unable to perform requested system backup, proceeding with builtin

  • Nithin
    • Support Wizard

    Hi drew_mathers,

    That’s an add behaviour, sorry to hear it’s still ongoing, we would like to see how enabling debug logs would help in giving a better idea about the connection to the WPMU DEV API side too.

    Since support access to your site was disabled, I wasn’t able to check what’s the status of Managed Backup in dashboard side.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );
    define('WPMUDEV_API_DEBUG', true);
    define('WPMUDEV_API_DEBUG_ALL', true);

    After making the above changes, please activate Managed Backup if it’s disabled, once the issue gets replicated again, the related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please do note that we are defining WPMUDEV_API_DEBUG, & WPMUDEV_API_DEBUG_ALL variables in the debug mode, which should help in giving a better idea if there is any issue within Hub side.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi drew_mathers,

    Sorry for the delay in getting back to you. You can either share the log files via Google Drive, Dropbox etc by sharing the link to log file in the next reply.

    If not, please send website credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    So, that we could give a closer look.

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -WordPress admin username

    -WordPress admin password

    -login URL

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant URLs

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Luís
    • Support

    Hi drew_mathers ,

    Hope you’re doing well today and sorry for the extreme delay in the reply. I followed the link you shared, but it asked me to “request access”. I have requested the access to luis.lopes (at) incsub.com.

    Once you granted permission to access to the file, please update this topic so we can get notified.

    Cheers, Luís

  • Nithin
    • Support Wizard

    Hi drew_mathers,

    Sorry for the delay in getting back to you. I could notice the ticket is marked as resolved, is the issue fixed?

    I checked the debug logs but I’m afraid it doesn’t give many clues regarding the issue. If you are still facing the issue, and want us to troubleshoot the issue further then please send your website credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -WordPress admin username

    -WordPress admin password

    -login URL

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant URLs

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi drew_mathers,

    Sorry to hear that the issue is still ongoing. Could you please send the login credentials as requested in my previous reply, so that we could troubleshoot this further, and also bring this into our developer’s attention for extensively testing regarding what could be causing too.

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • drew_mathers
    • Design Lord, Child of Thor

    The Automate update failed again today. This time, Managed Backup seems to still be configured. There is a Hub backup that appears to be in progress, but stalled.

    Managed Backup log shows:

    [Cron][2019-05-08 17:39:56][Warning] Immediate hook misfired, kickstart backup processing

  • Leonidas
    • Developer

    Hi there drew_mathers and sincere apologies for the delayed response.

    So, we checked your site last week and saw that managed backups are still properly configured there. Like you said, the issue is intermittent, so that is making it hard for us to reproduce and pinpoint the origin of your issues.

    Also, since you had logging enabled there and you mentioned on March 13th that backups have been deactivated again, we checked logs on March 12th that said again that there was no Snapshot key present at your install. We can now safely say that those deactivations are due to the Snapshot key being wiped out at some point for some reason. We will now focus on finding out that reason and push a fix for that.

    For that reason, we enabled extensive logging for a more verbose Snapshot log, which can hopefully helps us narrow this down. This means that, on top of those defines you were instructed to put on wp-config, we actually added define('SNAPSHOT_BACKTRACE_ALL', true); there as well,

    which I’m confident will put us in the right direction in case managed backups get deactivated again.

    We also put the debug.log in the File Exclusions of the managed backups, in order to figure out if your whole settings are getting wiped out at some point, when that backup deactivation happens, or if it’s just the Snapshot key that is being removed, which again will potentially help us figure out the culprit.

    You can keep a look at that installation and its set up managed backups, in case those get deactivated again. We will then go back in your site and check all the above I shared and hopefully we’ll be able to fix this once and for all. I’m certain that all this happening is a major inconvenience for you and I do want to again apologize you’re having this sort of issues, but I hope we can tackle this at its root, now that we set all the above up for any case of such occurrences in the future.

    Best regards,

    Leonidas

  • Leonidas
    • Developer

    Hi there drew_mathers,

    you mean that when backups get deactivated, you’re prompted to activate those, but not to provide a key again? If that’s so, that’s intended behavior for sites that actually have a key Hub-side, but need to exchange it again between the Hub and the site, because it’s not present in the site.

    In any case, I again took a look in your installation today and saw that backups got deactivated again between yesterday and today. Like I said in my previous message that I would, I checked if any other Snapshot configurations have been lost and indeed they were. Which makes us focus in a different area of where things may be going wrong.

    That being said, I’ve left a couple of error_log()s in your Snapshot codebase, which will again give us more insight on this issue. On top of that, we released today the latest Snapshot version which contains a fix for a really similar issue that some installations were facing and had to do with sites losing settings (much like yourself), especially on hosts with strong Object Cache enabled.

    Which brings me to my final point of how we proceed from now on: There’s a chance that the new version fixed your issues, which is obviously the best-case scenario :slight_smile: If that’s not the case, we left those additional error_log()s I mentioned above, to further narrow down the culprit for your issue. So, again if you please leave wp_debug enabled there and if there’s a new occurrence of backups getting deactivated there, let us know in this thread and we will take an updated look there.

    Best regards,

    Leonidas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.