[Snapshot Pro] managed backup not working

Have tried several times to make a backup of the site, and two times I have used chat support, where I have been instructed to add snippets to my wp-congfig file, witch I have done. Latest one was this;

define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);

define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);

define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

define('WP_MEMORY_LIMIT', '256M':wink:;

It has now been running for about 3 hours, and it still stands a 0%, so something is clearly not working properly. Support access is granted

  • Nithin
    • Support Wizard

    Hi Hakonzen,

    Hope you are doing good today. :slight_smile:

    I checked your website and could notice the issue. I don’t see any error in the console which seems to pinpoint more about the issue.

    Could you please add the following defines inside wp-config.php, and see whether it makes any improvement:

    define('SNAPSHOT_MB_BREADTH_FIRST', true);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);
    define( 'SNAPSHOT_BACKTRACE_ALL', true );

    Please make sure to place the above code, just before the line /* That’s all, stop editing! Happy blogging. */

    If the issue still remains the same then, please enable debug mode so that it would give a better idea. To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to run a new backup. Once the backup fails, the related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Kris
    • Support

    Hi Hakonzen

    I’m sorry for delay.

    Debug does not show any error related to snapshot here.

    To investigate this issue more I will need additional data from you. Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is “I have a different question” and:

    – Mark to my attention: ATTN: Krzysztof Tomczyk

    – Site access (login url / username / password)

    – FTP credentials (host / username / password)

    – Link back to this thread

    Please confirm here in thread that you have sent that message.

    Please also don’t share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it.

    Kind Regards,

    Kris

  • Kris
    • Support

    Hi Hakonzen

    Thank you for all details. I was able to modify snapshot defines in wp-config, but that also does not help. Snapshot throw an error:

    504 Gateway Time-out /nginx/1.10.3 (Ubuntu)

    Strange part is that even if we see this error, process of backup still run and backup file still being

    created in snapshot folder and size of this file still rise.

    I flag this ssue to our SLS Team (code experts) so that they can dig into this issue further for you. We will post an update here as soon as more information is available.

    Please keep in mind that our SLS Team deals with more complicated issues, so it may take a little longer for them to reply here. Thank you for your patience while we look into this further.

    Kind Regards,

    Kris

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hey Hakonzen ,

    I’ve tried various settings but the result is always a timeout from the server.

    I see that the produced .zip though is reaching always sizes of ~2gb. Could you please inform me how big the site is? Just in case there’s something else going on here as I’m not aware of the websites actual size.

    Also if possible we would like to have a CPanel or server admin panel access as well so we can cross-check if the server is reaching any limits and cutting of the process.

    You can send me the information needed privately through our contact form at https://premium.wpmudev.org/contact/#i-have-a-different-question by following this example:

    Subject: "Attn: Konstantinos Xenos"

    - Server Admin ( CPanel / Plesk )
    Username:
    Password:
    Login URL:

    - Link back to this thread for reference
    - Any other relevant URLs -or- information regarding the issue that was not included in this thread

    Regards,

    Konstantinos

    • Konstantinos Xenos
      • Rubber Duck Debugger

      Yes please, that would be of help as well Hakonzen .

      You can send me the SSH credentials instead ( please include any key as well if needed following the same instructions as my last reply ).

      If you say that your website is ~800mb and the .zip is reaching 2gb maybe there are some symlinks or some rare setup that drives the backup process into a loop. It would be easier for us to identify that by having server access in any case.

      I will get back to you as soon as we receive the credentials for a confirmation.

      Regards,

      Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.