[Snapshot Pro] Managed Backups give Other Kind of Backup Error

I cannot make managed backups in my site work. Firstly, it was giving out a time out error. Later, the chat representative went in and added the following constants in the wp-config.php file:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
@ini_set( 'log_errors', 1 );
define('WP_DEBUG_DISPLAY', false);
@ini_set( 'display_errors', 0 );
define( 'SNAPSHOT_BACKTRACE_ALL', true );

/* Snapshot Defines */
define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
define('SNAPSHOT_FILESET_USE_PRECACHE', false);
define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
if (!defined('SNAPSHOT_FORCE_ZIP_LIBRARY')) define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
define('SNAPSHOT_MB_BREADTH_FIRST', true);

/* WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

After adding the above, the database only backups were running and completing just fine. However, when including files in those backups, they instantly returned "Other Kind of Backup Error".
The debug.log and Snapshot logs have been attached in the chat transcripts. We have also done a full plugin/theme conflict test, which didn't help. Please advice.

  • Nithin
    • Support Wizard

    Hi Julie,

    Hope you are doing good today. :slight_smile:

    I tried to run Managed Backups and could notice the issue. I further changed the snapshot rules in wp-config.php to the following:

    define('SNAPSHOT_MB_BREADTH_FIRST', true);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define( 'SNAPSHOT_BACKTRACE_ALL', true );

    This seems to have improved the backup process, however, it did return an error after a while. I tried to check the memory resources by creating a file called info.php in your system, and by loading that in the browser side:
    your-websiteURL.com/info.php

    The memory_limit seems to be at 256M which is low. I'm afraid, setting memory_limit via wp-config.php doesn't seem to increase the server resources.

    I tried creating a php.ini file, and added the following rules:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    But it doesn't seem to make any difference. If you are using cPanel, please try whether the following article helps in increasing the limits to the above:
    https://www.copahost.com/blog/increase-php-memory-limit-cpanel/

    If that doesn't help, getting in touch with your hosting provider should help in increasing the server resources to the above, so that we could give a closer look regarding the issue.

    Please let us know how that goes, have a nice day ahead. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.