[Snapshot Pro] Managed Backups not working

The managed backups in my site keeps failing. The local Snapshots seems to be working fine. We have already tried increasing PHP's max_execution_time to 600 and memory_limit to 512M.
We've also tried adding the Snapshot optimization and backtrace definitions in the wp-config.php file, enabling WP_DEBUG and have attached the debug.log and Snapshot log files in the chat transcript. The backup error says "Other kind of backup error". Please advice.

  • Adam Czajczyk

    Hello Gonzalo

    I hope you're well today!

    I'll be happy to assist you with this but troubleshooting (and usually fixing as well) such issues requires a full access to the site, including FTP or - if possible - cPanel (to be able to access database and/or check CPU/memory/IO usage stats).

    Would you be able to provide me with such access credentials? It would be best if it was a staging site where we could safely do whatever has to be done without interrupting a live one.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Please note: we're a globally distributed company working from various places on the globe and we don't have any set of specific IPs so I can't provide you with any reliably stable IP to be whitelisted. If it's not possible to open FTP access without whitelisting specific IP, a cPanel access would work as well (actually, it would be great to be able to access it anyway).

    Best regards,
    Adam

  • Gonzalo

    Hi Adam, I’m trying to get an access for you.

    Meanwhile tell me if this error tell you something please.

    Error: Could not send file

    Google_0814_IO_Exception: Operation timed out after 100003 milliseconds with 0 bytes received in /home/emermedic/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/IO/Curl.php:81 Stack trace: #0 /home/emermedic/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/IO/Abstract.php(125): Google_0814_IO_Curl->executeRequest(Object(Google_0814_Http_Request)) #1 /home/emermedic/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(166): Google_0814_IO_Abstract->makeRequest(Object(Google_0814_Http_Request)) #2 /home/emermedic/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(409): Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\n\x00\x00\x00\x08\x00Z\xA3JM\x9C...':wink: #3 /home/emermedic/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(277): SnapshotDestinationGoogleDrive->send_file('/home/emermedic...':wink: #4 /home/emermedic/public_html/wp-content/plugins/snapshot/snapshot.php(7437): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/home/emermedic...':wink: #5 /home/emermedic/public_html/wp-content/plugins/snapshot/snapshot.php(7335): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker)) #6 /home/emermedic/public_html/wp-content/plugins/snapshot/snapshot.php(7659): WPMUDEVSnapshot->process_item_remote_files(1539203183) #7 /home/emermedic/public_html/wp-includes/class-wp-hook.php(286): WPMUDEVSnapshot->snapshot_remote_file_cron_proc() #8 /home/emermedic/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #9 /home/emermedic/public_html/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #10 /home/emermedic/public_html/wp-cron.php(126): do_action_ref_array('snapshot_remote...', Array) #11 {main}

    :Operation timed out after 100003 milliseconds with 0 bytes received

    Is this related to the max_execution_time set on my php.ini?

    I have bumped it up in order to avoid any issue with it.

    Attaching an screenshot.

  • Adam Czajczyk

    Hi Gonzalo

    Thanks, I'll be notified of your message and will check the case.

    The error that you're getting - yes, that seems to be related but I don't think it's related to max_execution_time. It looks like there's some connection issue with Google. Could you double-check the GDrive integration settings, please?

    If you go to "Snapshot -> Destinations" and click "Configure" for your Google Drive destination, it does show that it's authenticated an ready for use?

    Also, there's a directory ID option there. Can yo make sure that it's proper (following the description below that form field there) and is NOT any sub-folder? By "sub-folder" I mean a structure on Google Drive like this:

    /Backups/somesite

    so the folder ID should be for "Backps" and not for "somesite" or, in other words, it should be a folder in Google Drive "root" rather than any "deeper level".

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.