Snapshot Pro max execution time

Hi, I'm trying to set up Snapshot Pro, but I'm having troubles with the max_execution_time variable in my php.ini. The plugin needs at least 150 in this variable for restoring backups, but that number is higher than a typical permit number in shared hosting (right now I'm using Siteground Go Geek plan, 120 max in that variable). I already tried restoring a backup skipping the Fail in that variable setting, and the restore was incomplete.
Is there any chance of an update in this plugin (is one of the main reasons of having the subscription right now) so your clients can use this plugin in this type of hostings? I ask this because I tried Backupbuddy and other plugins for backups, and all of them works without a problem restoring the backups.
Regards

  • Adam Czajczyk

    Hello Jose,

    I hope you're well today and thank you for your question!

    I don't think it's said that the plugin really needs at least 150 seconds for max execution time as this requirement can be different for different environment. A higher value is suggested rather than lower but it's not always necessary and 150 seconds should in most cases be "with a safe margin" :slight_smile:

    You are referring to the "snapshots" feature ("Snapshot -> Snapshots" page) rather than Managed Backups feature of it, is that correct?

    Can you please tell me what is current WP memory limit of your setup to which you are trying to restore backup? You can check it by going to "WPMU DEV -> Support" page in your dashboard and clicking on "System Info" button, then switching to the "WordPress" tab and scrolling it all the way down. The value for "WP_MEMORY_LIMIT" would be the one we're looking for (not to confuse with WP_MAX_MEMORY_LIMIT)?

    What errors exactly are you getting when you attempt to restore backup?

    Let me know please.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Jose!

    Thank you for your replay.

    I initially assumed that's about "snapshot" backup feature of Snapshot plugin but I can see now it's about Managed Backups. You are attempting to restore a managed backup from within the site it was created is that correct?

    Could you, just for an additional test, try to restore that backup from scratch? To do this:

    - create some folder (empty) on your server
    - create a new, empty database
    - download backup file and snapshot-installer.zip file from The Hub (your WPMU DEV account)
    - put backup file on the server into that empty folder
    - unzip snapshot-installer.zip file and put snapshot-installer.php file into the same folder
    - run snapshot-installer.php via browser

    I'm wondering if that would work on your server so could you give it a go? Please note: do not remove your current site, perform the test on a new (empty) database and in separate folder so your site wouldn't be overwritten.

    Let me know about result, please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.