Snapshot Pro not backing up database for one of my sites

Hello,
I'm new here.
Right now I'm considering to switch off all of my premium plugins subscriptions and enter the magical world of WPMUDEV.
It's more pricey but integrated, managed and could really help me with my work.

I'm writing you now because I've found an issue and of course before the switch I need to be sure that everything works as I expect.

I've installed Snapshot Pro on a website (riflessologiazu.it) which is hosted on Siteground and everything was fine. Backup completed, both files and DB.
The problem came at the second try. I've installed SSPro on a website, which is still a work in progress (and freshly installed just a week ago), http://www.villaescondida2002.com/wp/. This is hosted on an italian "low-budget low-expectations" hosting provider, Aruba.it.
I can probably move the website elsewhere, but since in Italy many of the companies I work with have their websites on Aruba (they did a lot of TV advertising...) I need to know that it's something that can be solved directly on Aruba's servers.

The problem is this:
1. Snapshot Pro doesn't backup the DB!
Instead of the DB there is a 2Kb file called snapshot_manifest.txt. I've checked the forums, as you suggest, and most of the issues regards a "Missing snapshot Manifest" error. In my case, snapshot_manifest is the only thing I get!
2. Snapshot doesn't alert me of issues
Which maybe makes the problem even worse. I've a green flag on the backup operation: "everything is fine and in a safe place!".
3. I've just tried to backup the DB using Xcloner, which is a good free plugin I use when I need to switch to manual operation, and it backed up the DB without problems, creating a 1.6Mb zip file, so the DB is not the issue I guess...

Looking forward for your answer
Best Regards
Enrico

  • Bojan Radonic

    Hey there Enrico Frascati,

    How are you doing today?

    Since you're mentioning database and files separately I'm assuming you're referring to the regular Snapshots rather than Full Backups on our cloud servers?

    If you're referring to Snapshots there could be quite a few different causes but mainly these are memory being exhausted and timeouts preventing Snapshot from ever finishing. Before jumping into any conclusions would you mind granting me temporary admin access via our WPMU DEV Dashboard plugin so I can take a look? You'll find more information on how to do that here https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/.

    Also are you getting any errors when making a backup? Please let me know :slight_smile:

    Cheers,
    Bojan

  • Enrico Frascati

    Hi Bojan,
    thanks for your speed! :slight_smile:
    I've enabled support access for you.
    Yes, memory issues are typical on these servers but usually the plugins I used before give me alert of the issue. At the same time you have to consider that file backup, which is much more intensive, is completed correctly so maybe memory is not the culprit.
    And no, I've got no errors during backup.

    Well, take a look by yourself and let me know :slight_smile:
    Cheers
    Enrico

  • Bojan Radonic

    Hey again Enrico Frascati,

    At the same time you have to consider that file backup, which is much more intensive, is completed correctly so maybe memory is not the culprit.

    You're absolutely on point here, I just wasn't sure if you're doing a database backup separately or as part of Snapshot that included files and database so I was just mentioning that as a possibility.

    I've run 2 backups on your site, one with both files and database and other just database and both seems to be finishing properly which kinda explains why there are no errors, I'm not seeing anything in the log as well. The odd part is that when running a database backup Snapshot doesn't go through any of the database tables so to in order to dig into this further I'll need you to grant us FTP access so myself or if needed our developer can take a look.

    If that's fine first of all please DO NOT post any of the credentials here as forum threads are public but rather send us your details through our contact form https://premium.wpmudev.org/contact/ using this template:

    Subject: "Attn: Bojan"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Best regards,
    Bojan

  • Bojan Radonic

    Hey there Enrico Frascati,

    Thanks for sending the credentials :slight_smile:

    I've checked your site and turned on WP debug log to see if I can get any related errors and I've found this:

    [01-Nov-2016 11:06:28 UTC] WordPress errore sul database Access denied for user 'Sql46919'@'%' to database 'information_schema' per la query SELECT table_name FROM information_schema.tables

    After discussing this with our developer about information_schema this is just read-only virtual database in MySQL that has the information Snapshot plugin uses to check for the tables. The error pretty much says we don't have access to that which is the reason tables are not being shown.

    You can find more info about information_schema here: http://dev.mysql.com/doc/refman/5.6/en/information-schema.html

    Could you please contact your hosting provider and ask why are you getting access denied on that table and whether they can allow access so Snapshot can do its job :slight_smile:

    Let me know what they respond with :slight_smile:

    Cheers,
    Bojan

  • Enrico Frascati

    Hi Bojan,
    ok, I knew that the cause could be the provider... btw, in the meantime another website hosted on Aruba gave the same problem.
    Just a question, why is it that Updraft Plus and Xcloner (and other plugins I tried in the years) don't have and never had any problems with it? Of course I know you're the experts in this, but couldn't it be something to be addressed on your side too?
    In the meantime, thanks for your help.
    I'll update you as soon as possible
    Cheers
    Enrico

  • Bojan Radonic

    Hey Enrico,

    It could be that these two plugins are using different ways to fetch the tables info from the database, I'm not familiar with either of these two and the way they are coded so I can't really provide any valuable insight for that.

    What I can say is that this is really not a common issue, I didn't came accross this one on the forum before. After discussing this with our developer this really should be related to some sort of permissions issue on your server so hopefully this won't be too hard to change by your hosting provider.

    Please let me know :slight_smile:

    Cheers,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.