Snapshot Pro Restore Error "Aborting"

Hello I'm trying to transition an existing live wordpress to a localhost. I successfully made a Snapshot from my live site and it imports successfully into my localsite. But each time i try to restore it on the localhost i get "An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings." I believe my settings are correct and my snapshot is only 24 MB and should consist only of my database and active theme. All content/media and plugins were transferred manually. I've turned off all active plugins and am still getting this error. Any help would be appreciated! thanks!

    Sajid

    Hello Jacob,
    Hope you are doing good today

    That seems to be an issue with Snapshot media folder. First of all please make sure you have selected the correct path in Snapshot -> Settings -> Folder Location -> Backup Folder. Also, this folder should have read write permissions.

    If the issue continue, then enable support staff access for your live site so I could troubleshoot by downloading the zip archive and installing it on my own localhost site. To make sure the issue is with snapshot, zip archive or server setting.

    To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and have a nice day

    Best Regards,
    Sajid - WPMU DEV Support

    Sajid

    Hello Jacob,
    Hope you are doing good today

    Thanks for enabling support staff access for you live site. I downloaded the zip archive and tried to restore it on two of my sites. One localhost powered by locally by flywheel and second remote one hosted on westhost.

    It did not worked on both sites. I keep getting maximum nesting of 250 limited reached. Upon trying to increase it up-to 200 or unlimited, it started giving gateway time out error.

    Each time and on both sites, it stopping on prefix_options table. Once I deselected this table from archive, the backup works just fine for me.

    There is something wrong in the options table. Please deactivate any plugin on your site except Snapshot Pro plugin, create a zip archive and then check again.

    Once, I will have more information about this issue, I could then escalate this ticket to next level where I would include developer of the plugin.

    Hope that helps! Feel free to post a reply if you need further assistance

    Best Regards,
    Sajid - WPMU DEV Support

    Jacob

    Thank you for the insight! I did as you suggested and created a new snapshot with all of the plugins deactivated (minus snapshot and WPMU DEV) AND minus two that wouldn't allow themselves to be deactivated (layerslider WP and revolution slider). It was still failing with the options table. Does this mean that the issue is with Layerslider or Revslider? I then uploaded the snapshot with deselecting the options table like you did and it uploaded perfectly (but once uploaded, the site didn't work which i am sure you know it wouldn't). Is there a way to fix our options table? Any guidance would be appreciated! thanks!

    Sajid

    Hello Jacob,
    Hope you are doing good today

    Thanks for making the conflict test. Well, even if you disable those plugins, then it would still happen. Because, the issue is with data that is in the options table.

    The support staff access expired, could you please enable support staff access so I could download the zip archive again (the one I had is modified so would not work now).

    Take care and look forward towards your response, Jacob

    Best Regards,
    Sajid - WPMU DEV Support

    Sajid

    Hello Jacob,
    No problem at all and welcome back

    I see the old snapshot archive may be got delete on your site. Any way, I initiated a new snapshot backup archive on your site and will try it out.

    Also, did you tried using Managed Snapshot from WP Dashboard -> Snapshot -> Managed Backups ?

    If no then meanwhile give it a try and let me know if it is also not working for you.

    Take care and have a nice weekend!

    Best Regards,
    Sajid - WPMU DEV Support

    Sajid

    Hello Jacob,

    While creating the snapshot, when it reached to media files, it stopped with a 404 error as you can see in below screenshot.

    That mostly caused due to limited memory, execution and upload max file size settings. You can increase these settings by one of methods mentioned in this blog post.

    Before making the changes, note down the existing memory limit and execution time in WPMU DEV -> Support -> System Info -> PHP, so you could compare those later to make sure the changes are actually take effect.

    Take care and have a nice day!

    Best Regards,
    Sajid - WPMU DEV Support

    Sajid

    Hello Jacob,
    Hope you are doing good today

    Please try to move it to root folder, where you installed WordPress from wp-admin (one step back) and then check again.

    If still don't take effect then please try alternate methods mentioned in this blog post.

    If it does not work in any way, then it most likely your host does not allows you to change these settings locally. In this case, you would have to contact your hosting support and ask them increase the memory limits for you as requested.

    Also, please consider adding following constants/define in wp-config.php file before the line that says stop editing and happy blogging.

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10); //default is (250)
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100); //(default is 1000)

    This will divide the snapshot in smaller chunks and will keep including in backup archive.

    Hope that helps! Feel free to post a reply if you need further assistance!

    Best Regards,
    Sajid - WPMU DEV Support