Snapshot Pro results to Internal Server Error on certain (bigger) DB Tables

hey there,

I tried to get a DB backup with Snapshot on my website's DB. It works fine, but always exits on the same table with some statistic data so I create a job only for that table. Every time, regardless of the amount of memory or segment sizing, it stops at about 87 % of the ca. 300.000 entries. Annother table with some 200.000 entries more works fine but is 20MB smaller in size.
Data check on this table is fine, also optimizing, reparing etc.
A dump with phpMyAdmin results to a total 160MB SQL file without probs, except waiting...

furthermore there is no error with # 500 in php or server error log.

how can I fix this?

thanks for your feedback!

  • iRolf
    • WPMU DEV Initiate

    hello Jude,

    I tried to with various results: the PHP Memory is said to be 256MB the excution time can't be modified from webdev-userland and won't be changed by the provider.

    for that, the result is the same as above.

    to get rid of this backup issue, I tested a very dozen backup/clone/migrate plugins, but most of them fail with this database/runtime/memory issue.

    only Simple Backup dumps the whole stuff within the blink of an eye. that's kind of disturbing.

    is there a mysqldump thingy in snapshot I didn't figure out yet?
    that would be great to get the possible restore comfort from your plugin.

    cheers,
    rolf

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.