Snapshot Pro Settings Have Disappeared Twice

I have been using Snapshot Pro for about two months, and I have noticed that again (for the 2nd time!) that the settings for Snapshot Pro have disappeared completely. Here is how the screen looks when I login:
https://www.evernote.com/l/AAhEAtwszi5Lya0_kADXeIA2YN8TDOvH6AMB/image.png

I had previously configured Dropbox to be the destination of these saved files. Here is my dropbox folder's screen shot:
https://www.evernote.com/l/AAiF9riL3LdGxb7uz6V0Oqqru6M3_4baRLIB/image.png

You can see that as of today, Thursday, May 28, 2015, the backups had stopped for some reason a little more than 48 hrs ago.

1. Why do the settings of Snapshot Pro disappear completely? This has already happened twice.

2. What can I do to prevent this from happening? It is a little unsettling to me for three reasons. Firstly, I picked WPMU as the provider am paying a monthly fee for this service and expect it to work. Secondly, I am relying on Snapshot Pro to make regular on-going backups so I can sleep soundly at night knowing that everything is working well. And thirdly, when these issues keep happening and the settings disappear, I have to manually spend time to configure/reconfigure the backups to run again.

I want to have the confidence that I can rely on Snapshot Pro for doing these regular backups, and I am hoping you can help.

Regards,
Dustin Overbeck

  • Tyler Postle

    Hey Dustin,

    You're right that's not too reassuring is it. This is first time I've actually heard of this happening though. Let's get to the bottom of this shall we :slight_smile: Would you be able to provide support access so we can see what the settings of your snapshots are? If you've set them back up again.

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    This will help us troubleshoot and try to replicate the issue :slight_smile:

    This could also be server related as well, what sort of hosting/server do you have?

    Look forward to hearing back!

    All the best,
    Tyler

    PS. We have recently released a newer version you can upgrade too as well. 2.4.3.5.

  • Dustin

    Hi again Tyler,
    Apparently I cannot grant access. It says my account is Inactive:
    https://www.evernote.com/l/AAgfnscaLMVJK4JU8f4zy4kcRZEsOEJHE84B/image.png

    I did submit a support ticket earlier today saying that I could not request support, and was given the answer that it was a temporary issue with my account, but now it is active again:

    Hey Dustin,

    So sorry about that! Just checked your account and see that there was a temporary issue which caused your account to be shown as inactive. This was for a very short period of time, and by looking at your account all is sorted now!

    Could you please check that out and let me know if this works for you?

    Once logged in you can access support which is administered through our forums:slight_smile:

    You can post your questions or concerns directly through here: https://premium.wpmudev.org/forums/#question

    Looking forward to hearing from you:slight_smile:

    Please rate my reply:
    http://nicereply.com/wpmudev/63374?ticket=94002538/247455

    Kind Regards.
    Mike

  • Tyler Postle

    Hey Dustin,

    Thanks for the reply. Could you try granting support access again now? I just made sure your site selected for this question was the only one that had the dashboard API access enabled on it.

    If that still doesn't work would you mind sending your login credentials in privately to me?

    you can send this through our private contact form directly to me:
    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **no need to send in FTP right now, but it could save time later on if we end up needing it.

    Look forward to hearing back!

    All the best,
    Tyler

  • Dustin

    Hi again,

    I actually am unable to update the plugin automatically. This is what I click on:
    My Sites > Network Admin > WPMU DEV > Updates

    From here I get a screen that looks like this, with a button called "Auto Update" so I can update to Snapshop Pro 2.4.3.5:
    https://www.evernote.com/l/AAgzPzNVzxlAhJWJmjOrpVevkfXatviXMn0B/image.png

    However, when I click on the "Auto Update" button, I get the following Error:

    Downloading update from https://premium.wpmudev.org/wdp-un.php?action=download&key=9515fcd606083865fd2e7ab64ff66e70f59370e5&pid=257…
    
    Unpacking the update…
    
    Could not copy file. snapshot/lib/destinations/greenqloud/AWSSDKforPHP/lib/cachecore/_sql/mysql.sql

    Do you know what is wrong?
    Dustin

  • Tyler Postle

    Hey Dustin,

    Thanks for your reply here!

    This is usually due to a permissions issue. That file should have 644 permissions by default and the folder it is inside will be 755. WP engine has a feature in their WP dashboard where you can reset the permissions too, as seen in my screenshot - you can try doing that :slight_smile:

    Also, what version of PHP are you running?

    If it's still not working, you can always manually update through FTP by downloading the .zip plugin file from the project page: https://premium.wpmudev.org/project/snapshot/

    The download link right beside the install button.

    Then delete the snapshot folder in your plugins folder now and upload that file via: Plugins > Add New > Upload.

    I'd be happy to do this for you too if you send over your FTP - I've emailed you directly regarding this as well.

    Look forward to hearing back!

    All the best,
    Tyler

  • Dustin

    Thanks for the info. I logged into FTP and confirm that the folder was 755 and the file was 644. I wasn't able to figure out what version of PHP I am running. Since I'm with wpengine, I assume it is a later version or perhaps the most recent stable version.

    The problem in this thread is now two-fold. Originally it was because the settings in Snapshot Pro disappeared (twice on me!), and that the site backups stopped working completely and without my knowledge. This is really a big deal for me because when I set up the backups, I do not want to worry about it afterwards and would really rather not have to keep reminding myself to check and see if the backups are being performed.

    The 2nd problem that developed during the length of this thread is that Snapshot Pro cannot be updated automatically. I did follow your instructions from wpengine to click the 'reset file permissions' link, but upon doing the auto-upgrade, the same error message showed.

    Although I do appreciate the offer for two free months of WPMU Dev Premium, I really only needed to use Snapshop Pro.

    Given that this issue is now affecting my work for two weeks and counting, I would like to kindly cancel my subscription and get a 30 day refund for the last month. Unfortunately Snapshot Pro is not working out for me, and I really wish it would have.

    Thank you for your time.
    Dustin

  • Dustin

    I'm giving it one last try and documenting everything to see if I can find the error.

    1. I went to install the plugin, but it would not do it though the web interface.
    2. I installed the Plugin via FTP
    3. successfully installed and network activated it (I'm using Multisite)
    4. I configured an S3 bucket as a destination
    5. I created one new snapshot of a single site
    6. I ran a snapshot backup immediately to the S3 bucket just to test it
    7. I ran a restore of the file
    8. I created a scheduled backup to be performed hourly at have it execute 5 minutes in the future.
    9. Five minutes later I viewed the S3 bucket and see the backup file there
    10. Everything seems to be running, but I brought up the log file and found several errors. I do not know the meaning of these errors, but here they are on PasteBin for you to look at:
    http://pastebin.com/yG3SN8uJ

    Dustin

  • Tyler Postle

    Hey Dustin,

    Thanks for the update and glad you're giving it another chance :slight_smile:

    That error there wouldn't reset the settings at all. It looks like it tries to get the users then sql error happens. This could be caused by a memory issue. Are you reaching any limits on your hosting? I believe WPengine shows stats for this when you're logged into your account dashboard, or you could also email their support and ask.

    Look forward to hearing back!

    Cheers,
    Tyler