Snapshot Pro setup and run challenges

OK - so since Snapshot won't play with OneDrive, I upgraded my Google Drive to handle my 50GB+ backup for this site.

I went through all the setup instructions but on "Step 3: Authorise" I get a 'page not found' error. So I checked the setup according to the instructions. All good, hit "Authorise" again and, of course, get the same result.

So I think that maybe that's a quaint way of telling me it worked so I then set up and started the backup. Everything looked good for the first few minutes so I went and had a coffee while my SSD based/32GB of RAM server did the work. WRONG! I came back 20 minutes later to a Cloudflare 502 error message!

Now my server is fairly fast and I use the paid version of Cloudflare so there should not be an issue. But clearly there is since nothing arrived in my Drive account either.

Bandwidth is not the problem because I have about a gazillion TB or more. Can't be RAM because there's always at least 10gb in reserve and Snapshot only has access to 512mb.

I do run LiteSpeed but I sure hope that's not the issue.

Any suggestions?

David Wilks

  • Predrag Dubajic

    Hi David,

    Sorry to hear your having this issue with Snapshot :slight_frown:

    So the issue with backup is actually happening during the backup process, not during the upload to GDrive, correct?

    Can you tell me which max execution time you have set on your site and what's the storage limit on your server since file is created on your server first and then sent to GDrive?

    When you go your Snapshots panel does it create log file which could tell us what's going on?

    If not can you enable WP debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    After snapshot fails it should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • David

    Good morning,

    I have now spent a further six very frustrating hours on this. I started by running a fresh complete snapshot. I sat and watched patiently for the best part of an hour before getting a Cloudflare 520 error on the second last - but by far the biggest - stage, the uploads. After 3% the connection was broken between my system and the server BUT did that mean the process had failed?

    I then accessed the /_backup folder via CPanel and found two files there.

    The first, snapshot-backup.zip looked complete but was only 573.01mb. The second, snapshot-backup.zip.Bj8Y8U is 574.76mb.

    NEITHER backed up to my GoogleDrive so, using Putty, I laboriously moved them to the dev site where, when trying to restore them, I have the error message "Manifest data not found in archive'! (See attached screenshot.)

    Max exec time is 1800 and there is ample space on the drive.

    There are 50,000 + images in my Uploads folders and the site totals around 52GB. Has Snapshot been tested with a site of that size?

    David Wilks

  • David

    This is getting absolutely ridiculous! Ten hours later...

    So I excluded EVERY file and sub.directory in /Uploads. Then and ONLY then was I able to get a 'successful' backup (snapshot) BUT, the backup is 40.79mb from a site that is 52GB!

    As the next step I manually moved it to the desired account on my server, imported it - yes, successfully, and then tried to restore it. Guess what? Absolutely NOTHING happened. Zero. Zip. Zilch! No users, not posts or pages, no meta data. NOTHING.

    So I figure it's got to be me. I import it again, wash and repeat. Still nothing! That means after the best part of TWO days, I have absolutely nothing to show for my time. But according to this, https://premium.wpmudev.org/project/snapshot/ I have done everything correctly.

    Do I sound unhappy? I wonder why?

  • Predrag Dubajic

    Hi David,

    I understand your frustration, it's strange with all these things happening to you with snapshot, especially that even smaller snapshots are giving you issues.

    Could you grant me support access to your site as I would like to create few different snapshots and perform some tests so we can see if the issue here is with the size of your site or creating backup file itself?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • David

    Predrag,

    The real challenge is credibility. When I do a WHM backup to a tar.gz file, it is 42.9GB. That is about what I would expect. Yet the biggest file (which failed) created using Snapshot is just 573mb while the only 'successful' snapshot is just 40.9mb or LESS than 0.8% of the size of the live site. My SQL dump is 74mb alone!

    When I started this exercise, I had 117gb spare on my drive. I have since copied the /uploads folder across manually which has consumed 13gb and I have now moved a tar.gz file across - also manually - so that has consumed a further 42.9gb (52gb when I extract it) so there is not a lot of room left for you to experiment. Let me finish setting this dev site up and then I will update you with available space.

    (There is a second 'backup' drive with 300gb available but I don't know if Snapshot will be able to use that. Can it?)

    David Wilks

  • Predrag Dubajic

    Hi David,

    Snapshot basically depends on server configuration and we usually had similar reports on shared hostings or similar less powerful servers so in your case this shouldn't be an issue.

    Let me know when the staging site is configured so I could check it out, I will start with some smaller backup tests so there will not be much space needed but if you could ensure that it has around 5GB free it would be nice.

    (There is a second 'backup' drive with 300gb available but I don't know if Snapshot will be able to use that. Can it?)

    I'm afraid that Snapshot won't be able to pickup you backup drive :slight_frown:

    Best regards,
    Predrag