[Snapshot Pro] Several problem with backup

Snapshot not working on my website, backup not working, after several minute the operation crash

  • Ash
    • WordPress Hacker

    Hello Edoardo

    Sorry to know you are having issues. But I will need some more information.

    Are you trying to restore managed backup or regular snapshot? if regular snapshot, then which subsite you are trying to restore to?

    When you say, operation crush, do you see any error message on the screen? Possible to put a screenshot for me?

    And let's check if there is any server level error. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now, try to restore again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,
    Ash

  • Nithin
    • Support Wizard

    Hi Edoardo,

    Hope you are doing good today. :slight_smile:

    We'll need to troubleshoot further to see what exact issue is causing the backup to crash after a while. The initial steps to troubleshoot is to enable debug mode as mentioned in the 1st reply.

    Were you able to enable debug mode? If yes, could you please share the debug.log file as mentioned in the previous reply.

    If you still aren't sure how to enable debug mode, you can send us your sites login credentials, so that we could enable debug mode, and test what's causing the issue.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Edoardo
    • Flash Drive

    i have installed a lot of plugin, and remove, and change config ecc, but i have maked only the first backup and after this no one backup in scheduled it is completed

    Nithin all of credential is printed in support textbox in wpmudev dashboard

    the error is a simply 502 gateway error

  • Kris
    • Support

    Hi Edoardo

    Thank you for all details. I made some snapshot test on your site to replicate this issue. I also get error: 504 gateway error.

    I review ftp and I exclude debug.log file in snapshot settings, it is over 200MB.

    I also add some snapshot defines to your wp-config.php file:
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    This one help for simple snapshot. I was able then run snapshot and make full backup called:
    Snapshot test wpmu full multisite

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS',true);

    Those defines help for managed backups, I was able to run full site backup also there.

    Hope this help :slight_smile:

    Kind Regards,
    Kris

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hi Edoardo ,

    I've taken a look at your issue and I see that pretty much all of the WordPress files have wrong permissions and Snapshot can't read them to create a backup. For example the permissions for .php files are 604 instead of 644 and that might be making them non-readable.

    Could you please contact your hosting provider with this information so they can "re adjust" the permissions on your website to the WordPress default ( they vary from setup to setup that's why you have to contact them ).

    Inform me when that's done so I can check if the backups are working normally again !

    Regards,
    Konstantinos

      • Konstantinos Xenos
        • Rubber Duck Debugger

        On the latest Snapshot update, we added a check to automatically skip the non-readable files. This update was released on 8 January, if you see your backups dates that's when they stopped since the permissions were not correct and Snapshot is automatically excluding them to avoid the previous errors that we had reported.

        The files need to have the correct permissions else they will be discarded from backups, so please contact your provider to reset them back to normal as I've mentioned on my last reply.

        On a further note the 604 permissions that the files currently have doesn't seem correct in any case. Is there a possibility that something happened changing the permissions without you noticing as well? The files should have 644 most likely instead.

        Regards,
        Konstantinos

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Edoardo , I have one question because I see that the FTP account you've provided might not have correct permissions everywhere to change the permissions of the files ( different groups etc so more access might be needed to change all ). Is there maybe an Admin Panel provided by the server? Like Cpanel/Plesk or something like that which would make it easier ?

    You can send me the information needed privately through our contact form at https://premium.wpmudev.org/contact/#i-have-a-different-question by following this example:

    Subject: "Attn: Konstantinos Xenos"
    
    - Server Admin ( CPanel / Plesk )
    Username:
    Password:
    Login URL:
    
    - Link back to this thread for reference
    - Any other relevant URLs -or- information regarding the issue that was not included in this thread
  • Konstantinos Xenos
    • Rubber Duck Debugger

    Edoardo ,

    We have finished fixing the permissions and we've taken a backup as well. You can see it in the Managed Backups section with today's date.

    Now I have to inform you about one extra thing that we've discovered on your host so you can be fully informed. It seems that there's a really low Timeout directive set for the server ( we don't have access to change that ) so sometimes and as the website grows bigger if you try to run a Managed Backup manually (with the Run Now) command it might give you a 504 timeout error.

    This doesn't happen with Automated backups that are on schedule though so those will work fine as they use a different system. Please re-check your Automate / Managed Backups settings to see if they are still on schedule :slight_smile: .

    I'm informing you just in case you could contact the host ( maybe they could be helpful at this part ) to raise that timeout and avoid any problems in the future.

    In any case as I've said the backups are running fine now as far as I can see so the issues with the permissions etc is solved as we've addressed that via FTP.

    Tell me if you need any further help!

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.