[Snapshot Pro] Snapshort Pro + Amazon S3 - 403 Forbidden response

Hi there,

I'm trying Snapshot Pro for the first time and I'm thrilled to set this thing up with Amazon. But something doesn't work here on my end.

I've made a bucket in S3 and also see this bucket in Snapshot Pro, so the Amazon credentials are correct. Since I try to make sure I have the correct server I've set up this Bucket with the EU Ireland server because that one is listed in Snapshot Pro as well.

So I've:
connected my Amazon S3 bucket with Snapshot Pro correctly. Servers are equal (Snapshot Pro and bucket), Storage type is Standard but still get this error below.

Please help :slight_smile:

Connecting to AWS
Using SSL: YesError: Error executing "HeadBucket" on "https://BUCKETNAME.s3.amazonaws.com/"; AWS HTTP error: Client error: `HEAD https://BUCKETNAME.s3.amazonaws.com/` resulted in a `403 Forbidden` response (client): 403 Forbidden (Request-ID: 3F1117143893659D) -

  • Nahid

    Hey there Justin !
    Hope you are having a great day!

    I'm sorry to hear about the issue that you encountered. I tried to replicate the issue in a test site of ours but couldn't.

    According to our developers, one of the common reasons for such issue is having some other plugin enabled on the site that includes/uses either an older/conflicting version of AWS SDK and/or Guzzle library (one of the PHP HTTP client libraries).

    Could you please take a look at your site and see if you're aware of any such plugin(s)? If not, could you please try doing a full plugin/theme conflict test just to make sure no other plugin(s)/the theme on your site is/are conflicting with Snapshot Pro and thus causing the issue. The basic concept is to temporarily disable all the plugins except Snapshot Pro and WPMU DEV Dashboard, switch to a default WordPress theme and check if the issue still persists. If it doesn't, please enable all plugins and the theme one after another to see activating which brings back the issue. This handy flowchart can help you do a full plugin/theme conflict test.

    If the plugin/theme conflict test doesn't help, could you please enable WP_DEBUG? You can enable debugging by putting the following constants in the wp-config.php file:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    These constants must be added before the line "/* That's all, stop editing! Happy blogging. */" for them to work. Please make sure identical constants are replaced if they were already there previously.

    Enabling debugging in WordPress will log any errors that the site encounters in a log file named "debug.log" located in the "wp-content" folder. Please upload the debug.log file in a cloud storage platform like Dropbox and attach the shared link in your next response so that we can take a look into it. You can know more about WordPress debugging in this handy article.

    Note: It is highly recommended that the site is backed up in an alternative before the tests or the tests are done in a cloned staging site.

    Hope this helps. We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

  • Andy

    I'm not sure if you ever resolved this Justin but I ran into exactly the same error on my new setup using Snapshot Pro (new member) and it turned out it was due to the Access Key being in an old format.

    If you login to S3 and go to https://console.aws.amazon.com/iam/home?#/security_credentials I received a warning saying that keys needed to be updated due to a change in the way S3 works. I created a new Key pair and put it into Snapshot Pro and it worked immediately.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.