[Snapshot Pro] Snapshot errors

I'm trying to run my first backup and I'm getting two errors.
https://gyazo.com/51af47f0b0e727c5be1b2e8dda68f6aa
https://gyazo.com/9510e65af0b7b862ffe1510841040cc2

  • Adam Czajczyk

    Hello Cameron

    I hope you're well today and thank you for your question!

    The second (404) error seems to be caused by server timeout. This often happens if either some server resources are "maxed out" due to too strict limits on a server but it's also happening often because of some very large files included in backup (the first "General" error might be suggesting this).

    That said, you might want to start with checking your WordPress install directory against big files such as some .zip files, backups made with other plugins and similar. Then you can exclude such files or entire folder using "Global exclusions" option on the "Snapshot -> Settings" page.

    Would you give it a try? If that doesn't help, I'd need to take a closer look at your site and WordPress installation.

    In such case, please:

    1. Enable support access to the site by going to the "WPMU DEV -> Support" page in site's back-end and clicking on "Grant support access" button there.

    2. Once that's done, please put cPanel (or, if it's not available, FTP) access credentials - URL/host, login, password - in the text box below the "Access active for X days" message on "WPMU DEV -> Support" page.

    Note please: message that you add in step 2 above will not be posted anywhere and I'll only be able to see it after I access your site's back-end; it will safely stay within your site.

    I will not be notified about that also so let me know here once you're ready, please (just do not post any access credentials here; only let me know that access is granted and information added there).

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Cameron,

    I have tried excluding Uploads folder from the backup and then it worked fine, so it seems there's something in there taking up too much resources and breaking the backup process.
    I wanted to have a closer look at your uploads folder so I tried using provided FTP details but I'm afraid that I don't see lifeof*****.com folder on your server.
    Can you please add folder path in support message box (below the login details) so we can investigate this further?

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Cameron,

    That can indeed affect the backup because processing it will require more resources from your server.
    You can go to Snapshot > Settings panel and in there you will see "Global File Exclusions" field.
    In that field add /uploads/audio and that will exclude that folder from the backup.

    Let us know if the backup completed properly after that.

    P.S. We only needed the folder path so I've removed your IP and masked the site URL from the above comments.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Cameron

    That would mean that either there's still some huge file to be excluded or that's not the only issue and some other aspects must be checked.

    Unfortunately, the support access to the site seems to be no longer active. Could you please enable it again and let me know here once it's done?

    Please make sure also that valid FTP credentials are still there in a note under the "Access active for X days" button on the "WPMU DEV -> Support" page in your sit'es back-end and if possible, could you also add cPanel (or other server management panel that you're using) access credentials there?

    Let me know once you're ready and we'll keep investigating that.

    Best regards,
    Adam

  • Adam Czajczyk

    Hi Cameron

    Thanks, I was able to access the site and the server.

    I checked it and I was able to replicate the issue. I found out that there are still some big files there, for example some backup files in wp-clone folder that's well over 2GB in size.

    Therefore, I've added to more folders to global exclusions and tried to run managed backups. I actually waited until it completes and it run fine up to over 70% while before adding those exclusions the error was showing up pretty fast (less than 10% progress).

    Unfortunately, at that point I got logged out from the site (I should have been keeping other part of the wp-admin open in additional tab and reload it from time to time to avoid that) and since getting to 70% itself took quite a long time, I wasn't able to try that again. However, taking into account that up to that point it run smoothly and nothing showed up in Snapshots internal logs, I think that there's a good chance that this should make the trick.

    I made sure that backup is scheduled - currently it's set to daily at 1am - so please wait until the nearest scheduled time passes by (so nearest 1am), then wait a couple of hours more to let it actually process files and upload them and then please check the site to see if this time backup was completed.

    I think it should be but let's make sure so update me here, please.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Cameron

    I accessed the site again and did some more "heavy tests" on it. It took a few hours but I think we're down to resource issues after all, most likely related to I/O limits ("input/output" which basically means the limit on file read/write operations - usually speed).

    The backup process is, by the nature of it, quite "resource hungry" - it makes thousands of if not millions (depending on the site complexity) of such operations and that not only puts quite a bit of "stress" on server but also might cause those I/O limits to "hit the wall". That in turn can either cause backup scripts to time out, server to temporarily slow down or even go down etc, which, in turn, would result in backup fail.

    I added some "tweaks" for Managed Backups to the "wp-config.php" file to lower down the resource usage a bit but so far to no success (though please keep the lines that I added to "wp-config.php" there). I also run multiple backup attempts and then switched to testing snapshots ("Snapshot -> Snapshots").

    This is a bit different "engine" and it's working in a bit different way but it did let me to look "more into" whats going on "behind the curtain" which, eventually, led me to that conclusion on resources.

    There are two things though that I'd like to ask you to try as those might actually limit the "stress" that backup puts on server so there's a chance it might help:

    1. Is there an option to upgrade/switch PHP to a newer version? Currently the site is powered by 5.6x but if it is possible to upgrade to 7.x (preferably 7.2.x) it's definitely worth giving a try. It should increase site's overall stability and performance so as a "side effect" you can actually notice a speed boost but what's most important - it's just faster and less "resourceful" so it might help here.

    2. If that alone doesn't help then, apart form big files that are already excluded, I found a bit database table that might also 'cause issues as the server might not be able to handle it properly in all cases during creating the .zip file (which it does "on the go").

    The table is "wp_wsal_metadata" and comes from the Audit Log plugin that you're using on site. The table alone, when extracted from database to the file, is over 200MB in size. Therefore, it might worth to try to "shrink" it significantly. I'm not sure if the plugin allows you to export the logs but if not, in order to keep backup of these logs and "shrink" the table at the same time, you could do as follows:

    - first, create a snapshot ("Snapshot -> Snapshots") of that table only, this should work fine, I tested it already - so set it to "no files" and "selected tables only", selecting only this specific table
    - then download that backup file to some safe location to keep it in order you needed to get back to these logs (you could then import it to any database via phpMyAdmin in case you needed to check it)
    - then go to that Audit Log settings and try to set as short log maintenance period as possible and clearing up all the old data

    If these two changes (PHP and Audit Log clean up) doesn't help either, I'll include our developers in the case but I'm afraid it might be necessary to contact host to see if I/O limits could be increased.

    Best regards,
    Adam

  • Cameron

    Thanks for all that, Adam. BTW, I've been trying to roll out Snapshot across my other sites too and I've had mixed success so far. I'll talk to my sysadmin about the version of PHP this site is running. I recently migrated it to a new server and one of the reasons we did that was to put it on the latest version of PHP, so I don't understand why it's still running on 5.6.

    cheers
    Cameron

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.