[Snapshot Pro] Snapshot - failed at icl_string_pages

Hi,..
My snapshot always failed at " _icl_string_pages "

I try to create different config. only media, only theme, only plugin work but when I add database it failed and it always failed at " _icl_string_pages "

to different destination:
- drive
- local
- managed

Also try this:
> https://stackoverflow.com/questions/42859377/table-icl-string-pages-decrease-performance-of-site

but it doesn't resolve this problem

I looked at this table and it's huge ... how to clean it ?

have any advice ?

  • Adam Czajczyk
    • Support Gorilla

    Hello Julien Ferla

    I hope you're well today and thank you for your question!

    The current version of the WPML is much newer than the one addressed in this stackoverflow post so I believe this particular problem reported there was already solved.

    However, if the table is huge that might pose a problem in some cases. How big is it and where are you hosting your site currently?

    Would you mind enabling support access to the site for me so I could try to run snapshot there and check the browser console to look at what's going on during the process "under the hood"? I'd also like to check site configuration as this might give some clue on why it fails.

    In order to enable support access, please go to the "WPMU DEV -> Support" page in your site's back-end, click on "Grant support access" button there and let me know here once it's done.

    Best regards,
    Adam

  • Predrag Dubajic
    • Support

    Hi Julien,

    Apologies for the delay and thanks for granting access.
    I had a look at your backups and can see that you have a DB backup created already but I also tested it once again and created a temp backup with your entire DB which finished without any issues, including the "_icl_string_pages" table.

    So it seems that the backups are working properly, but when your files and DB are backed up together it requires more resources than your server is letting you use so it fails.
    This could also be caused if the backup is performed while there's high load of your site due to number of visitors so I would suggest setting up scheduled backups, one for files and one for DB and set them to be done at times when there's low activity on your site.

    About the DB cleanup, perhaps this discussion on WPML forum could help you with that:
    https://wpml.org/forums/topic/string-translation-clean-up/

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.