[Snapshot Pro] Snapshot fails to upload to Google

My backups fail to upload to a Google Drive for storage. I got this error today:
Error: Could not send file <pre>Google_0814_Exception: Failed to start the resumable upload in /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php:290 Stack trace: #0 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(138): Google_0814_Http_MediaFileUpload->getResumeUri() #1 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(409): Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\x14\x00\x00\x00\x08\x00ZF1M\x7F...':wink: #2 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(277): SnapshotDestinationGoogleDrive->send_file('/home/crookedri...':wink: #3 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/snapshot.php(7435): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/home/crookedri...':wink: #4 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/snapshot.php(7333): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker)) #5 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/snapshot.php(7657): WPMUDEVSnapshot->process_item_remote_files(1537188617) #6 /home/crookedrivercabi/public_html/wp-includes/class-wp-hook.php(286): WPMUDEVSnapshot->snapshot_remote_file_cron_proc() #7 /home/crookedrivercabi/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #8 /home/crookedrivercabi/public_html/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #9 /home/crookedrivercabi/public_html/wp-cron.php(126): do_action_ref_array('snapshot_remote...', Array) #10 {main}</pre> :Failed to start the resumable upload

  • Jayman Pandya

    Hi Mark,

    I tried replicating your issue on my website but was unable to. The Snapshot uploaded successfully to Google Drive. But I was able to see the issue on your site.

    Can you verify whether the Directory ID is correct or not?

    If it is correct, I would suggest to delete this Destination and add it again. It has solved this problem for me in past.

    Let us know if you need any further assistance.

    Thank you
    Jayman

  • Mark

    I don't believe the process worked properly when you tried it. There are no files in my Google Drive. This account is only used to store backup files and its a brand new account and there are no files there at all.
    So my only option is to delete the destination and start over? I have this problem with Snapshot to Google on several sites. Almost everyone I've ever tried it on. Are there other issues going on?
    thanks, mark

  • Jayman Pandya

    Hi Mark,

    I saw that you have created a new Google Drive Destination and i tried taking a Snapshot and upload it to Google Drive, It failed with the same error that you have reported.

    I will escalate this to the Second Level Support team. Please give them sometime to look into this and assist us in fixing this. I will request you to be patient as the response time of Second Level Support is longer than First Level Support.

    Thank you for your patience.
    Jayman

  • Mark

    Is there any progress on this issue? I just ran another snapshot and I'm getting the same message about uploading to Google but so far it doesn't appear in the drive folders. You have support access to my website but just in case here's the error that was just generated:
    Error: Could not send file

    Google_0814_Exception: Failed to start the resumable upload in /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php:290 Stack trace: #0 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(138): Google_0814_Http_MediaFileUpload->getResumeUri() #1 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(409): Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\x14\x00\x00\x00\x08\x00PH5M\x7F...') #2 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(277): SnapshotDestinationGoogleDrive->send_file('/home/crookedri...') #3 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/snapshot.php(7435): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/home/crookedri...') #4 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/snapshot.php(7333): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker)) #5 /home/crookedrivercabi/public_html/wp-content/plugins/snapshot/snapshot.php(7657): WPMUDEVSnapshot->process_item_remote_files(1537534931) #6 /home/crookedrivercabi/public_html/wp-includes/class-wp-hook.php(286): WPMUDEVSnapshot->snapshot_remote_file_cron_proc() #7 /home/crookedrivercabi/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #8 /home/crookedrivercabi/public_html/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #9 /home/crookedrivercabi/public_html/wp-cron.php(126): do_action_ref_array('snapshot_remote...', Array) #10 {main}
    :Failed to start the resumable upload

  • Dimitris

    Hello there Mark,

    hope you're doing good today and don't mind me chiming in here!

    In order to double check that connection is not a problem, I added a second destination in your site using my own Google Drive credentials. Then I created a little new snapshot that contained only the .htaccess file and this was successfully uploaded to the new destination (named: "wpmudev":wink:.
    You can see it's status here: https://www.yourdomain.com/wp-admin/admin.php?page=snapshot_pro_snapshots&snapshot-action=view&item=1537539339&snapshot-noonce-field=5a41cfe1d8

    I also reviewed your connection once more and I can see that your "CRCgoogledrive" destination isn't fully connected. I can't tell if this a latest change, if so, please disregard.
    If not, please follow up the highlighted instructions to complete the integration:

    After editing your destination and connecting it correctly, you can run the "Snapshot GDrive Test" that I used, which is very very small, to quickly test how's that going (it should be uploaded in ~5mins or something, at least this happened to me).

    Looking forward for your results! :slight_smile:

    Warm regards,
    Dimitris

  • Mark

    Thanks for working on this. I edited my google connection but the snapshot still fails to upload or even connect. I ran a snapshot and uploaded to your google drive successfully so its clearly something in my google api connection. It seems like once problems start with Google API its hard to fix. I created a Dropbox destination and have successfully uploaded there so I think I'll stay with that for now. thanks again.

  • Dimitris

    Hello there Mark

    I'm really sorry for this, I wish I could setup this for you, but you should share your Google account with us and I don't know if this is desired (not to mention that Google can cut us off, if we try to login from unknown -to you- places).

    Let me make clear that you should:
    - first enter the "Name" and "Directory ID" (via instructions)
    - then enter the "Client ID" and "Client Secret" of your Google App (use the "Redirect URL" in your Google App)
    - the authorise the destination (you should login with the same Google Account who created the Google App)
    - finally "Save Destination" to complete the integration

    Thank you,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.