[Snapshot Pro] Snapshot is not working

Snapshot is not working. Every time it is being run we are facing issues like the job not getting completed or receiving the error. Link for the upload file that got generated by the suggested code snippet from WPMU Dev support forum:

https://drive.google.com/file/d/1J0PbxWp5Xer262HkmJ8rUhSYPkKWv4Oz/view?usp=sharing

  • Kris

    Hi Abhijeet

    I'm sorry to hear that you are experiencing this issue.

    To better check this issue I will need some additional data which will help me to check server resources and review all files on ftp. Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is "I have a different question" and:
    - Mark to my attention: ATTN: Krzysztof Tomczyk
    - Site access (login url / username / password)
    - FTP credentials (host / username / password) or cPanel details (login url / username / password)

    - Link back to this thread

    Please don't share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it.

    Also please confirm here in thread that you have sent that message.

    Kind Regards,
    Kris

  • Kris

    Hi Abhijeet

    I'm afraid this access not telling me all.
    max_execution_time is 10000
    memory_limit is 2000M
    So this cannot be issue with server resources.

    While running simple backup in Snapshot I notice those table which are included in backup and are part of database:

    _wfblockediplog
    _wfblocks7
    _wfconfig
    _wfcrawlers
    _wffilechanges
    _wffilemods
    _wfhits
    _wfhoover
    _wfissues
    _wfknownfilelist
    _wflivetraffichuman
    _wflocs
    _wflogins
    _wfnotifications
    _wfpendingissues
    _wfreversecache
    _wfsnipcache
    _wfstatus
    _wftrafficrates

    Those tables comes from Wordfence plugin which does not exist on your site anymore, there is no need to store in database tables which increase weight of database.

    Also while this process I notice that snapshot try to ZIP folder "BACKUP" which exist in uploads. This mean you could have there some large ZIP files from other backup plugin.
    After over 30min Snapshot fail at 60% in /uploads/elementor/tmp (it freeze there for about 5-7min, so I guess this folder can contain large files or many files).

    As for managed backup in Snapshot it freeze at 0% all the time.
    Please note simple snapshot make backup of themes, plugins, uploads folder and database, while managed backup incude as additional: whole wp core folders including all folders which are not part of wp core.

    So without access to FTP I cannot fully review uploads folder which could store some large files (pdf, mp4, ZIP backup files from other plugin in past, etc.) or does some month folder store large number of images (like over 1000 or 2000). Also I cannot review any additional folder which could be not part of wp core.

    Could you in this case fully review your ftp and add this code to wp-config.php file:

    /* Snapshot Settings */
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    /* End of Snapshot Settings */

    Those defines should be placed above the "/* That's all, stop editing! Happy blogging. */"

    and then run managed backup again from:
    /wp-admin/admin.php?page=snapshot_pro_managed_backups

    Kind Regards,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.