[Snapshot Pro] Snapshot is way too slow, and for local BU's get's stuck

This is more of a "rant" I suppose, so polite apologies in advance. Here goes:
I’m disappointed with Snapshot. From a previous chat, I made all of your recommended PHP changes, including max_execution_time to 250, memory_limit at 128M, and upload_max_filesize to 128M, and still backing up to your managed (amazon) server took several hours for a 125mb site! Actually, I gave up at 48% for this one. Incredibly long backup times have been the case with every site I've backed up to the managed site so far, and none of these sites were over 250mb. In one case, I upgraded from PHP 5.6 to 7.2 to see if that would help, and I got an error. Tech support at Newtek (my host in Phoenix) looked at the log and noticed a security issue with Snapshot for 7.0, thus I had to stick with 5.6. A security issue of this sort is a bit un-nerving guys.

So I tried backing up a couple of sites to a local destination. Things looked good and fast until the progress bar hit 87% for one site and 77% for another site, and then they both got stuck for over an hour each, and finally I got 404’s. BTW, I tried these one at a time.

I have a lot of sites to manage, 81 accounts, and was planning to keep adding them into my Hub. I was hopeful for a more automated solution that WPMU seems to represent. However, I'm not so sure now; I may be wasting my time after all. Managing sites individually at least gets me what I need, albeit with more difficulty and more time. Backing up is a critical feature for your suite of products. I think you need to do some serious work on Snapshot. I’ll give this experiment with WPMU another month, and if Snapshot can’t be improved, at least to run with PHP 7+, and more efficiently, I’ll cancel my account, and WPMU won’t get a good review from me. Sorry for this. I'm actually a nice person, but I'm testing you right now. I want to stay, and if you can give me some genuine assurances that Snapshot can work as advertised, I'll be happy to stay with WPMU. Please help.

  • Nastia

    Hello Rod

    Hope you are doing well!

    Let me explain that Managed Backup is backing up the whole root directory where your site is located, so it is backing up other folders, that may other WordPress installation or non-Wordpress files that may be located in that folder.

    Backing up a 125MB site should be quite faster than several hours for sure. Though it looks like it takes this much time because, I assume, it is backing up the whole public_html directory

    Please go on your site to the Snapshot > Settings, under "Global File Exclusions" add folders that you want to be excluded from the backup. Please let us know if the backup speed will be increased.

    In the wp-conifg.php file please try adding this line, it will exclude from a backup other files that are larger more than 100MB

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //~100MB

    If you have added these lines in the wp-config.php file:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    This will slow down the backup process. These lines are reducing the backup chunk size, therefore the Snapshot doesn't use much of server resources during backup. If these are added to your wp-conifg.php file, to save server resources, try increasing the chunk size from 10 to 50 and if needed from 50 to 100. Please do the same for the Table Chunk Size, from 100 to 500, and if needed from 500 to 1000.

    Please let us know how it went!

    Kind regards,
    Nastia

  • Majid

    Hey Rod
    Regarding the folders to backup, usually the root folder would be the "www" directory, but sometime this one contains many other folders in case the server is hosting many sites, so you need to find the root directory of your site. to do that you can use our WPMU DEV Dashboard plugin, WPMU DEV > Support > System Info, and switch to WordPress tab just like in the screenshot.

    I hope this helps!

    Cheers,
    Majid

  • Rod

    Hello again,

    As an update, in settings, I excluded every file and directory in the root except public_html. www was excluded also, FYI. In wp-config.php, I bumped up the chunk sizes as follows:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 1000);

    Then, about 45 minutes ago, I ran another backup, or should I say I'm running another backup, which, as I write this, is at 43%.

    I also ran a backup from cPanel, which included the public_html directory and the MySQL database, which took all of 4 minutes. I did this comparison because I was concerned that the server resources at the host and/or the local connection in our building might have been slowing things down. Not the case, evidently.

    Honestly, I'm not sure what to think about using Snapshot for my business. Again, I like the automation (I'm busy enough designing and managing sites), but I simply can't understand why a backup this small would take so long. Thing is, some of my sites are very large, complex, and well over 5GB. At this rate, backing up sites like these could take days!

    Suggestions?

    rod

  • Nastia

    Hello Rod

    Hope you're doing well!

    The backup time should not take so much time, a 50MB backup has been completed form my end within 7 minutes. Would you please send to us your credentials so we could have a closer look at your site and see if we can increase the backup speed?

    You can send credentials by using our secure contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Looking forward to your email!

    Kind regards,
    Nastia

  • Dimitris

    Hello there Rod,

    hope you're doing good and I'm really sorry for the late response here.

    I went ahead and made the following changes in following server files:
    .user.ini
    added:

    memory_limit = 512M
    max_execution_time = 3000

    wp-config.php
    added:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);
    
    // Snapshot settings - start
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);
    // Snapshot settings - end
    
    define('WP_MEMORY_LIMIT', '256M');
    define('WP_MAX_MEMORY_LIMIT', '512M');

    After connecting via FTP, I was able to see the following folders that aren't part of WP installation:

    so I already added them in Global File Exclusions in Snapshot settings.

    Now, please disable either HummingBird -> Caching or WP Fastest cache, as they are conflicting each other most probably.

    Finally, I can see from WPMY DEV -> Support -> System Info, that you're running PHP v.5.6.36. If you could upgrade this to v.7.x. it'd be awesome! Your server panel should give your this capability, if not, better advise your hosting provider.

    After making above changes, please do try to run a new Managed Backup and let us know about your results! :slight_smile:

    Thank you,
    Dimitris

  • Myke

    I've tried it on several sites - small and large. When the site is small and it takes a half hour to freeze at 26%, that is just too much. By comparison, UpdraftPlus and similar plugins, finish this quickly for any of these sites - I just wish they had a central hub for all my sites.

    This looked promising, but never works out. So far, anything WPMUDEV other than Autoblog has seriously slowed my sites down when I have tried them - even Hummingbird. If Snapshot doesn't work, it makes all the auto update features of the hub less useful. I have that happening through cPanel/Installatron for most sites, but was hoping to use this for those hosts where Installatron is not installed.

    I just upped all the limits - memory, execution time, etc - then excluded my entire uploads folder, it took 15 minutes to get to 5% and I cancelled it.

    It would be really nice to be able to use this so I could also use the Automate feature.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.