[Snapshot Pro] Snapshot Managed backup doesn't complete

Snapshop doesn't complete a managed backup. It starts and then stops with "<empty response>" on the screen where the progress bar was.

The site based the initial minimum requirements check before I started. I did not navigate away from the screen.

  • Nithin

    Hi Jenny,

    I ran a Managed Backup in your website, and could notice the same issue. Could you please add the following defines inside wp-config.php, and then check whether you could run a backup without any issue?

    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);

    wp-config.php resides in the root directory, and you'll have to use FTP, SSH, or cPanel login to make the above changes.

    If you still get the same issue even after making the above changes, then would recommend you to temporarily disable all the plugins in your system, except WPMU DEV Dashboard, and Snapshot, and enable debug mode, so that we could check the debug logs.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to the run a new new backup, along with other plugins disabled as mentioned before. If the backup fails again, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.