[Snapshot Pro] Snapshot managed backups not running on schedule

I have it set up for weekly backups but it's not running. Log says: [snapshot][2019-01-18 05:55:52][Warning] Unable to perform requested system backup, proceeding with builtin

  • Nahid
    • Tech Support

    Hey there Cameron !

    Hope you are having a great day!

    I’m sorry to hear about the issue that you encountered. In order to help you better with the issue, could you please let us know a bit more details? Does this only happen in case of scheduled backups or do the once-off backups fail as well?

    I wasn’t able to replicate the reported issue in test sites of ours, so I believe it is something specific to your site. Could you please go through the following troubleshooting tests which would help us determine the source of the issue?

    1. Enable debugging: Please enable WP_DEBUG. You can enable debugging by putting the following constants in the wp-config.php file:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    // Snapshot Backtrace
    define( 'SNAPSHOT_BACKTRACE_ALL', true );

    These constants must be added before the line “/* That’s all, stop editing! Happy blogging. */” for them to work. Please make sure identical constants are replaced if they were already there previously.

    Enabling debugging in WordPress will log any errors that the site encounters in a log file named “debug.log” located in the “wp-content” folder. Please upload the debug.log file in a cloud storage platform like Dropbox and attach the shared link in your next response so that we can take a look into it. You can know more about WordPress debugging in this handy article.

    Note: It is highly recommended that the site is backed up in an alternative way before the tests or the tests are done in a cloned staging site.

    2. Send Credentials: Could you please send us the access credentials to your site and server so that we can take a closer look at the issue? You can send that privately through our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: “Attn: Nahid Mohit”

    – WordPress Login URL

    – WordPress Admin Username

    – WordPress Admin Password

    – FTP/cPanel credentials to the site (host/username/password)

    – Link back to this thread for reference

    – Any other relevant URLs

    Hope this helps. We’ll be looking forward to hearing back from you. Thanks!

    Kind regards,

    Nahid

  • Nahid
    • Tech Support

    Hey there Cameron !

    Hope you are having a great day!

    Thank you for sending the credentials in. I took a closer look at your site and it seems the WordPress Cron has been disabled in the wp-config.php file. Snapshot’s Scheduled Backups are based on WP Cron events, which schedules the backups to run on preset timings. In your wp-config.php file, I was able to see the following line of code:

    define('DISABLE_WP_CRON', true);

    Is there a specific reason that it has been added? If not, could you please try removing it and see if the Scheduled Backups work then?

    Hope this helps. Please let us know if this works for you. Thanks!

    Kind regards,

    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.