[Snapshot Pro] Snapshot not uploading to GDrive

Just setup Snapshot -- but these are not uploading to my GDrive. Get error: Error: Could not send file <pre>Google_0814_Exception: Failed to start the resumable upload in /home/drivere5/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php:290 Stack trace: #0 /home/drivere5/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(138): Google_0814_Http_MediaFileUpload->getResumeUri() #1 /home/drivere5/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(409): Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\n\x00\x00\x00\x08\x00\xC6|HMO...':wink: #2 /home/drivere5/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(277): SnapshotDestinationGoogleDrive->send_file('/home/drivere5/...':wink: #3 /home/drivere5/public_html/wp-content/plugins/snapshot/snapshot.php(7437): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/home/drivere5/...':wink: #4 /home/drivere5/public_html/wp-content/plugins/snapshot/snapshot.php(7335): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker)) #5 /home/drivere5/public_html/wp-content/plugins/snapshot/snapshot.php(7659): WPMUDEVSnapshot->process_item_remote_files(1539013018) #6 /home/drivere5/public_html/wp-includes/class-wp-hook.php(286): WPMUDEVSnapshot->snapshot_remote_file_cron_proc() #7 /home/drivere5/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #8 /home/drivere5/public_html/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #9 /home/drivere5/public_html/wp-cron.php(126): do_action_ref_array('snapshot_remote...', Array) #10 {main}</pre> :Failed to start the resumable upload
------------------------------------
I have given you access to this multisite. Suspect there is something amiss in the GDrive set up.