[Snapshot Pro] Snapshot not working on two sites

I’m getting this error…

Error: Could not send file <pre>Google_0814_IO_Exception: Operation timed out after 100009 milliseconds with 0 bytes received in /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/IO/Curl.php:81 Stack trace: #0 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/IO/Abstract.php(125): Google_0814_IO_Curl->executeRequest(Object(Google_0814_Http_Request)) #1 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(166): Google_0814_IO_Abstract->makeRequest(Object(Google_0814_Http_Request)) #2 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(404): Google_0814_Http_MediaFileUpload->nextChunk('\xB5\x8Byp\xB4\xDB\xFD\xFA%;\x1E5\xA8\x04\xD2...') #3 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(272): SnapshotDestinationGoogleDrive->send_file('/home/kinkeep/l...') #4 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/snapshot.php(7663): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/home/kinkeep/l...') #5 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/snapshot.php(7561): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker)) #6 /home/kinkeep/letsjustbe.us/wp-content/plugins/snapshot/snapshot.php(7885): WPMUDEVSnapshot->process_item_remote_files(1570499566) #7 /home/kinkeep/letsjustbe.us/wp-includes/class-wp-hook.php(286): WPMUDEVSnapshot->snapshot_remote_file_cron_proc() #8 /home/kinkeep/letsjustbe.us/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #9 /home/kinkeep/letsjustbe.us/wp-includes/plugin.php(531): WP_Hook->do_action(Array) #10 /home/kinkeep/letsjustbe.us/wp-cron.php(133): do_action_ref_array('snapshot_remote...', Array) #11 {main}</pre> :Operation timed out after 100009 milliseconds with 0 bytes received

  • Kris
    • Support

    Hi randomblink

    Hope you are doing good today.

    From what error say this could be related to low server resources.

    Could you please provide support access for this site so I can take a closer look on this.
    Right now I see access is open but it does not work. Please disable and enable once again.
    You can grant support access via WPMU DEV > Support > Support Access
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Kind Regards,
    Kris

  • Kris
    • Support

    Hi randomblink

    From what I see max_execution_time is set up to 200 and memory_limit is 256M. Which is enough for sure as backup was made correct. Issue exist only when backup need to be send to google drive.

    I enter your Destination Info -> Google Drive and I click Re-Authorize button it gives 400 error.
    This mean something is wrong with this settings in this destination.
    Could you double check yout settings in Google API Console and compare them with those which you add in Snapshot settings?

    Kind Regards,
    Kris

  • Nithin
    • Support Wizard

    Hi randomblink ,

    So I went to a site where Snapshot was working fine and I deleted everything and reset it up… Now that site is doing the same error.

    Could I know which website is that? Are all the website where you notice the issue hosted in the same server?

    If it’s all hosted on the same server, could you please double-check whether you are running the recent version the cURL library? ie version 7.40 or greater?

    Also, could you please double-check with your hosting provider there are any firewall or security modules ie mod_security which might be blocking any outgoing cURL requests?

    Please do let us know how that goes so that it would help us in ruling out what all instances might have caused such an error to occur. Have a nice day ahead.

    Regards,
    Nithin

  • randomblink
    • Site Builder, Child of Zeus

    From my webhost…

    We have now update curl in the server to version 7.66
    Please refer the details pasted below for your reference.

    [rootNuno ~]# curl -V
    curl 7.66.0
    Could you please check with them and get back to us with their IP address or any particular rules which is causing this block.

  • Ash
    • WordPress Hacker

    Hi randomblink

    I have tried to re-authorize, and I found the oauth client is deleted message. Then I have usedmy API and cred and it was authorized. Here is a screencast: http://recordit.co/4DGY8sndTd

    So, I don’t think the server has any issue, it must be the credentials permission.

    I have removed my cred from the settings form after testing.

    Would you please create a new project, add the site in that project, create a new oauth client ID and try again?

    Let us know how it goes.

    Cheers,
    Ash

  • randomblink
    • Site Builder, Child of Zeus

    I don’t know what to think at this point.

    I have created a new project, added the site, new oAuth, the works… What is really bugging me is that I KEPT GETTING THAT DANG ERROR… I never checked my drive… But I did a couple ONCE OFF snapshots to test… they threw the same error, but a couple of them… NOT ALL… came through into the drive…

    I have NO idea what to do. I really want to use this for my clients. I have too many sites to manage to NOT back them all up… But I really don’t wanna pay for anything yet…

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.