[Snapshot Pro] Snapshot Pro Backup Failures

After a very helpful and lengthy discussion on live chat with Kris Tomczyk yesterday, although we were unable to resolve this issue. I have yet to be able to create a successful backup of any of my sites using Snapshot Pro. TARANDFEATHER.TV is one that continuously fails at 92% when it gets to the "plugins" directory. We tried a number of things, outputting logs, disabling all plugins, etc. all to no avail and no pinpoint problem in the logs. Kris also tried doing it locally, which also failed so we eliminated Google Drive as being the issue. On HALFSTOP.TV, I am able to "successfully" initiate a backup, although it never completes the upload process, just continuously for over 24 hours says "uploading" in the status with a spinning wheel, and nothing shows up in the destination folder on Google Drive (which is fully authenticated and checked out via API Key, etc.). Basically, I need to get the functioning properly on all 3 of my sites linked to WPMUDEV.

Thanks!
Travis

  • Kasia Swiderska

    Hello Travis,

    I'm sorry to hear that Snapshot is not working correctly on your site. I have checked console log while taking backup and discovered that backups is stuck when this error shows:

    admin-ajax.php 404 (Not Found)

    this error is most often related when I/O Usage hits its limit.
    If you have ability to see I/O usage in your hosting please check that while taking a backup - it will probably rise. If you don't have access to this type of data please contact you provider and ask if they are observing unusual spikes of I/O Usage on your account and let us know.

    This issue is usually present on shared hostings (like lower level of GoDaddy).

    kind regards,
    Kasia

  • Travis Button

    Hi Kasia,

    Thank you for your reply. Yes, actually this is something I had noticed by complete accident in my cPanel dashboard and brought up to Kris in our first conversation (see attached). The I/O Usage gets maxed out a lot during the process but goes up and down depending on where it's at in the backup process. It actually maxes out a lot but doesn't cause it to fail until that particular point everytime.

    I am on a higher tier Cloud hosting package and in talks now with the host as to whether or not that I/O can be increased or not. Is there not some sort of flag we can input into Snapshot Pro so that it limits the transfer rate if for some reason I'm not able to get this cap increased by my host?

    Not sure what methods Snapshot uses exactly but I have been able to successfully backup my site using Updraft without issue. Thoughts?

    I'll followup once I hear back from my host on the possibility of increasing that I/O.

    Additionally, any thoughts on my other site that does succeed but never uploads the backup?

    Best,
    Travis

  • Travis Button

    Hi Kasia,

    First, I'd say since I never received a response from you regarding my site that did "successfully" create a backup but never uploaded. Attached, 3 days later is a screenshot from that which still says "uploading....". Thoughts on that?

    Now, Here is a fairly detailed response from my host support team regarding the TARANDFEATHER.TV issue failing with Snapshot Pro (In a netshell it says the problem is not with the server, but with the plugin):

    Hello,

    Thank you for the patience so far!

    We have performed a detailed investigation on this case and here is the gathered information.

    After strictly following the above-provided steps, a backup creation has been successfully initiated.

    During almost the whole process your account was using the following resources:

    ID SPEED MEM IO IOPS
    tarandfe 40% 333 4208 7

    Constantly, 4MB of I/O is being allocated and that is quite normal. Since a backup creation is currently ongoing and there is a lot of read and write processes, the tool will use as much as I/O available.

    I/O Limit is the maximum cumulative disk reads and writes. If your account exceeds your I/O limit, CloudLinux will slow down the processes, causing them to execute slower.

    Furthermore, the processes are still working, they are not killed, but the load time is slower.

    Since there is a process that is hitting the limits of the I/O the same will be slowed down so that it uses the available resource per package. Eventually, the same should fully complete if the max_execution_time is not low.

    The max_execution_time value represents how much time a single process could run before it is killed by the server. A value of 30 causes a certain process to be able to run for 30 seconds, once the same process reaches 31 seconds it will be killed by the server.

    Therefore, prior to initiating the backup process, we have raised the max_execution_time value to 30000 which is more than 8 hours.

    However, as you described the process reaches a point where the backup creation stops. The same is being killed by the server prompting that no process is currently running on that PHP request.

    We suspect that the issue might be either related to the plugin or the backup plugin could be in a conflict with the rest of the installed ones.

    What we could suggest is to try using a different backup plugin and check whether the issue will still be presented.

    Another option is to place your website in maintenance, disable all of the active plugins and run the backup tool once again.

    Considering the information above, please do update us here at your earliest convenience.

    Kind Regards,
    Marcus Evans
    Genius Support Team
    TMDHosting.com

  • Kasia Swiderska

    Hello Travis,

    Could you please send in the following via our secure contact form so we could try more troubleshooting this issue on your sites https://premium.wpmudev.org/contact/#i-have-a-different-question :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include cPanel credentials (if possible)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • Travis Button

    Hey Kasia,

    Sent your requested info over in the manner you said. I'd suggest maybe so people don't accidentally reveal this kind of sensitive information publically, you guys create a very distinct option in the submission options that says "Public" and "Private". Just a thought.

    Thanks and look forward to hearing more back on this issue. At the end of the day if we don't get it working, I guess that I could use an alternative for backing up but since I'm already spending $49/mo for my WPMUDEV account, I'd like to manage everything under your suite of plugins for consistency.

    -Travis

  • Kasia Swiderska

    Hello Travis,

    I did few more attempts to create backup and seems that it works if I split snapshots to separate parts: DB, media, themes and plugins. I created successfully smaller snapshots this way instead of one big one.
    I tired also to upload to Google Drive, however it throws error
    Google_0814_Exception' with message 'Failed to start the resumable upload' in

    In this case can you check that you have enabled Drive API for your created project? (Sometimes it gets disabled, so shows this error) Also, would you please rename your project and try to re-authorize?
    Let me know if its done and if you are able to send a smaller, like only DB backup to the google drive.

    kind regards,
    Kasia

  • Travis Button

    Hi Kasia!

    Thanks for looking further into this and you know I had thought of trying this method but never got around to it. As long as I could setup 4 different automatic weekly backups (one for each type of data) then this should work out fine.

    I am literally walking out the door in the next few minutes for a camping trip where I'll be off the grid entirely so I'll followup with you on this Friday when I return to the office in regards to the API key, changing the name, re-authorizing, etc. so we can figure out why the Drive Upload is failing.

    Just wanted to let you know I've gotten your response and I will respond asap once I return.

    Best Regards,
    Travis

  • Jack Lavender

    It would be great if, when setting up Google Drive destinations, Snapshot Pro would actually save some small file to the Google Drive. I've had multiple installations fail because the Google Drive API wasn't enabled and that would be clear if SSP tried to save a file.

    And related to that, the item number 3 in the setup process says to enable the Drive API. It is not nearly as detailed as the other steps and is pretty critical. Something like, "Once your Project is created or selected, go to the API Dashboard and click the blue, +Enable APIs and Services to enable the Google Drive API."

    • Travis Button

      Totally agree. The enabling of the API is a bit obscure. On the Google side, not that anything ever happens with them based on customer feedback but you'd think that when you create a project/key for the first time that it would automatically enable the API or at least give you a warning that it hasn't been enabled yet and in order to use your key it needs to be enabled. None of which happens.

      Thanks for the added input on this thread!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.