[Snapshot Pro] Snapshot Pro - Gateway timeout

Hi, i have been following your guide here: https://premium.wpmudev.org/blog/sync-staging-live-sites-wordpress/ and was making a copy of my live site, but every time the progress bar gets to 48% and i get Gateway Timeouts (504). Both Max execution time and max input time are 10000 odd and the memory is 1024m.

I have a couple of screengrabs to show if required, but it's when it's handling the media folder it stops.

Any ideas?

  • Patrick Freitas

    Hi Piers

    Sorry to hear that you are having this issue.

    Wouldn't you mind please to grant the support access and send me the FTP information and I can have a closer look on the problem.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    -Steps that you are taking, the screenshot will help.
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Please, let me know when you send me the FTP information.
    Have a great day,
    Patrick Freitas

  • Patrick Freitas

    Hi Piers

    I fixed a similar issue using this snippet on wp-config.php

    Note, always do a backup of edited file, or use it on a stating site.

    Wouldn't you mind please, using FTP, access the WordPress root Folder > wp-config.php and above /* That's all, stop editing! Happy blogging. */ use the following snippet:

    /* Snapshot Settings */
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip'); // optional settings are pclzip or ziparchive
    /* End of Snapshot Settings */

    It makes the plugin works with less images on the same time.

    Let me know the results,
    Best Regards,
    Patrick Freitas

  • Patrick Freitas

    Hi Piers

    You can try to add one more code:

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB

    I would suggest you enable the Debug Mode and check if any debug.log would be generated.
    On the wp-config.php

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    Execute the plugin again and check for any debug.log on WP root Folder/wp-content/, change the .log to .txt and attach on reply.

    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.