[Snapshot Pro] Snapshot Pro not functioning

I have debug enabled and no errors are being recorded. I have added define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
define('SNAPSHOT_MB_BREADTH_FIRST', true);
per the recommendation of chat support. I have attempted to try managed backups yet i get timeout messages. I am trying primarily to get the website completely backed up to dropbox. I am currently unable to do so. I have max execution time set to 300 as well which I believe is the highest my host allows for however, the inactivity timeout happens much earlier than 300 seconds either way. in the snapshots section when you view the recent dropbox attempt you will notice that it says it is still uploading. I have been at this for a little over a day now and not a single file has been uploaded so I cleared all of those zombie attempts and tried a new one. I got the same error and it shows as "uploading" still under the snapshots page. Again, no errors have been recorded at all in the new debug log that was created. I have seen 3 different backup errors. such as "Other kind of backup error" , "INACTIVITY TIMEOUT
Description: Too much time has passed without sending any data for document." and "AAA An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings."
At this point I have no idea what is going wrong with it and no errors are being recorded for me to attempt to make sense of it. Any help would be amazing. Thank you

  • Steve

    I am not sure if this matters at all for this particular issue, but I do see now after about 40 minutes of trying this again something has written into the error log but it is seemingly unrelated to the issue with snapshot pro. either way, here it is..

    [17-Jul-2018 04:43:47 UTC] PHP Notice: Trying to get property of non-object in wp-includes/class-wp-query.php on line 3736
    [17-Jul-2018 04:43:47 UTC] PHP Notice: Trying to get property of non-object in wp-includes/class-wp-query.php on line 3738
    [17-Jul-2018 04:43:47 UTC] PHP Notice: Trying to get property of non-object in wp-includes/class-wp-query.php on line 3740
    [17-Jul-2018 04:43:47 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at wp-includes/class-wp-query.php:3736) in wp-includes/feed-rss2-comments.php on line 8
    ***Note*** I did remove the absolute path from this log note.

  • Adam Czajczyk

    Hello Steve

    I hope you're well today!

    I have accessed your site and run a new test snapshot there. It does indeed times out with 504 error. It seems that the "real timeout" is actually 30 seconds only, despite what "is set" and what it detects. I also noticed that in request headers some sort of "proxy" reports and this is what seems to be closing connection.

    I see that you're hosting with GoDaddy but I'm not sure about the server configuration. What I'm trying to say here is that it might be a server-side issue where the PHP does have max_execution_time set to 300 but still some sort of "proxy" server/module is cutting of the connection at 30 seconds threshold. But I'm not 100% sure of that.

    I would like to investigate it closer but I'd need better access to the site to be able to do this. Would you please send in full access credentials to me?

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Your message would be delivered directly to me and I'll then use these credentials to access site and server in order to track down the issue.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hi Mike

    I hope you're well today and welcome on board!

    This ticket is already a few months old and the backup issues often require individual troubleshooting even if the "symptoms" look similar at the first glance. Would you please start your own separate ticket about it?

    To do this, please go here:

    https://premium.wpmudev.org/hub/support/#get-support

    then select "Technical support" and from there you may either join a live chat support session (24/7) or create a support ticket on this forum. Please also make sure that before doing that you have enabled support access to the site. This can be done by going to the "WPMU DEV -> Support" page in the site's wp-admin area and clicking on "Grant support access" button there.

    We'll then check the site and assist you with the issue in order to solve that.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.