[Snapshot Pro] snapshots regularly disappear

Hi,
All my snapshots (more than 500) are gone after update, even the destination in AWS. Hopefully they are on the AWS server but no more listed in my wp-admin so no more running crons. Yesterday I made a few new ones on local destination and today they are gone in their turn (but still the recordings are there).
I have granted you support.
Is there a way to recover the missing 500 (after fixing the issue of course) ? it would take me too long to redo it.

  • Adam Czajczyk
    • Support Gorilla

    Hello siteweb

    I hope you're well today and I'm sorry to hear about the issue.

    I understand that you're talking about "snapshots" as in "backups configuration" on "Snapshot -> Snapshots" page, right?

    I've accessed the site (didn't make any changes there whatsoever so far) and I can't see snapshots there like they were never there. You mentioned that this happened after upgrade but we didn't have any reports on such issues so far and I just tested the update procedure on one of my test setups - all the snapshots were carried over as expected.

    Can you tell me please if this was only Snapshot update or some other updates at the same time?
    Was there any backup restored - especially to the main site - around that update time (if not from Snapshot then from e.g. some host backups)?

    Were there any other changes made such as for example:
    - changing database table prefix
    - adding/removing some plugins?
    - adding/removing/tweaking some code (especially custom code) on site?

    Let me know please.

    We'll also need to investigate it on this specific setup in order to try to find out what happened. For this we'd need full access to the site and server so we could check install files, site and server configuration and error/debug logs and the database. Would you be able to provide those?

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Please also do not make any changes on the site such as: downgrading, removing or reinstalling Snapshot plugin, creating new snapshots, restoring site/db from some other backups or making any direct changes to the database. This could affect the related data in the database.

    Once I receive credentials from you I'll pass them directly to one of the Snapshot developers who'll check this. I've already discussed that with him so he could assist us with this.

    Best regards,
    Adam

  • siteweb
    • Site Builder, Child of Zeus

    Hi,
    I didn't test, I was really upset to have lost 500 snapshots cron, given the time it took to create them and the time it will take to create them again. Knowing it's the second time this plugin let me down, the first time with 300 snapshots I rebuilt. I am wanting to give it a try but I need to know if you have found the issue or I will suffer another time the loss of the snapshots.
    So let me add a request : it will be great to generate automatic snapshot creation each time a new blog is created, or once for every blog of the network. So loss won't be a big problem anymore.
    Thanks for having remind me your help.

  • Umesh Kumar
    • Code Wrangler

    Hey siteweb,

    I can understand the amount of re-work that you must have done and I'm really sorry about it. To make this right I'm trying to get to know the issue and fix it sooner so that you don't have to put in so much time to backup the sites manually.

    I need to know if you have found the issue or I will suffer another time the loss of the snapshots.

    No, I haven't because I don't have enough details to be able to replicate this at my end. And that's why I need your help in here.

    So let me add a request : it will be great to generate automatic snapshot creation each time a new blog is created, or once for every blog of the network. So loss won't be a big problem anymore.

    So let me try to understand this, you want an option in Snapshot settings to enable automatic backup for any new site created? Which I can definitely add to the list of feature requests. But then how does this setting helps you with the loss?

    or once for every blog of the network. So loss won't be a big problem anymore.

    Were all the backups stored locally? Even if they weren't, the backups don't get deleted automatically unless the plugin was uninstalled.

    About the lost backups I can still check your setup and find out if the backups are still stored in server. For that I'd need full access to the site. Would you be able to provide those?

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Umesh Kumar"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Thanks, Umesh

  • siteweb
    • Site Builder, Child of Zeus

    Hi,
    Thanks for replying.
    I will give you the login details in a few minutes.
    I have tested the update 3 days ago. And the 2 snapshots I created before disappeared as well as the destination (on AWS). The thing I have noticed this time is that the disappearance occurred after updating the network. Snapshots were still there after the update of the plugin but not anymore after updating the tables of the network.
    You have to know I asked my host provider to send every 24 hours the backups on the AWS bucket from the local directory because they didn't go automatically (due to my host security settings), so this is why they are no longer here.
    Kind Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.