Snapshot Pro Stalling when Creating New Backup

Hey!
Having an issue with Snapshot stalling when creating a new backup. it gets all the way through and stalls when backing up plugins. i have increased memory limits in snapshot setting and wp config to 1G and 256m.

its strange because i had just created a new snapshot which succeeded. when trying to create another new snapshot is when i started seeing the stalling issue.

any help is much appreciated!!

  • Rupok

    Hi rc1, hope you had a wonderful day.

    That's weird. Actually it's pretty tough to conclude why this is happening but I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Can you turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi rc1,

    Hope you are doing good today. :slight_smile:

    Thank you for providing your observations, this could also mean a plugin folder is causing a conflict with Snapshot while taking a backup. Does your debug.log produce any error? If not, please check the wp-content/uploads/snapshot/_logs folder for any error in the particular backup, if you find a related incomplete log file, you might see that the last process would be that particular plugins backup.

    I hope this helps. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello rc1,

    Is snapshot supposed to be used for migration? or is it more of a local backup tool that can be configured for migration with some tweaks?

    Original purpose of Snapshot is backup tool - but it can be used for migration as well (single to single WordPress, subsite for Network to Single - but not single WP to subsite in Multisite).

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Nithin

    Hi rc1,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I made multiple backups. I tried replicating snapshots based on your "Snapshot_noMUPlugins" settings, and even with & without mu-plugins, but I'm still able to create Snapshot without any error or stalling, could you please check and confirm whether you are still having this issue? I found full backups to work fine in both your destination, I have deleted half of the test snapshots I created, please delete the other once you check it.

    Please advise if I had missed out anything, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi rc1,

    Hope you are doing good today. :slight_smile:

    It's really odd, but now I'm able to confirm your snapshot is taking long, and still no backup. I changed the compression library settings to zipArchive, under Snapshot > Settings > Compression library. And now it seems to work. Could you please check, and confirm?.

    Stalling has a lot to do with max_execution_time, and I was able to notice that the value is set to 0, you can check that under WPMU DEV > Support > System Info.

    It seems like a plugin is overriding the max_execution_time value to zero, I think it's the IDX broker plugin, since it's a premium plugin I'm not able to figure out where the plugin sets the value to 0. If you still have issues with creating new snapshot backups, would recommend that you try disabling all your plugins, and then try taking a snapshot, and check whether it makes a difference.

    If you have a low max_exeuction_time in your php configuration for eg: 30, would recommend that you increase it to atleast 180. Depending upon your hosting, you'll have to add the following lines to your php.ini or .user.ini file:
    max_execution_time = 180

    You can find more info about changing the values here: https://premium.wpmudev.org/blog/increase-memory-limit/

    I hope this helps. Please let us know if you need any further help. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.