[Snapshot Pro] Stuck at 80% and keep getting 504 error.

Hello, I am trying to restore a backup but I am getting a 504 gateway timeout.

  • Neel Gajjar
    • Staff

    Hello Nathan,
    how are you doing today?

    The error that's showing up means that that the server powering the site is not able to process requests "on time". If you could see that max_execution_time in your site is set to 0.
    By default on all the WPMU DEV hosted site max_execution_time is set to 300.
    But in your case, it was changed to 0. This might be the reason why there was 504 ERROR.

    After further investigating the issue about why max_execution_time is set to 0. I noticed that
    WP ALL EXPORT is setting the max_execution_time to 0.

    Can you once deactivate that plugin and try to restore the Managed Backup you have?

    If you are able to successfully restore the site you can activate the WP ALL EXPORT plugin again.
    And then follow these steps.
    Access the files via FTP
    1. Visit > Public_html > Wp-content > Plugins > wp-all-export > config > Download the options.php File.
    2. Open the File in a text editor
    3. Edit the file change max_execution_time value from 0 to 300.
    4. Save the file and re-upload it.

    I would also inform you that all the site hosted at WPMU DEV, we have 30 days backup which can be restored by the visiting hosting panel.

    To restore
    1. Visit this link
    https://premium.wpmudev.org/hub/hosting/
    2. Select this the site name you want to restore
    3. Visit Backup
    4. Select the date you want to restore the site.
    5. click on 3 dots > Click on restore.

    It contains the last 30 days backup.
    For more infromation, you visit the below link :
    https://premium.wpmudev.org/docs/hosting/backups/

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Kind Regards,
    Neel Gajjar

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.