[Snapshot Pro] Unable to perform a backup and unable to upload snapshot to google drive

I have been Unable to perform a backup and unable to upload snapshot to google drive.

Backups just whitescreen and the snapshot will not upload giving an error for resumable upload.

  • Prathamesh Palve
    • Staff

    Hello Jess,

    I need to investigate this further to understand the exact issue here. Would you mind turning ON the support access for us to investigate the issues further? Here is how you can turn ON the support access:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#enabling-support-access

    Kindly reply in the thread here once you enable the support access so we would be notified of the same. Have a great day ahead.

    Thank you,

    Prathamesh Palve

  • Nastia
    • Support Rock Star

    Hello Jess

    Trust you're doing well!

    Please increase site's PHP memory that is set to 40MB to 256MB and max_execution_time that is set to 30 to 150seconds.

    To do so, please add the following line in the wp-config.php file, above /* That's all, stop editing! Happy blogging. */:

    define('WP_MEMORY_LIMIT', '3000M');

    And add the following to php.ini:

    max_execution_time = 150

    If there is no php.ini file exists, please feel free to create it and place it in public_html folder. These are a minimum requirments for the Snapshot plugin to run. To verify that the changes are applied, please go to WPMU DEV > Support > System Information.

    I've checked local snapshot and small backup as a full site's backup are running on your site.

    The upload to Google Destination, however, showing the following error:

    Error: Could not send file Google_0814_Exception: Failed to start the resumable upload in ../path/.. Failed to start the resumable upload

    It looks like an API related issue. I've created a new Google Destination on your site connected to my account, and it was uploaded successfully. Please see a backup named "Snapshot – test". Feel free to remove this Google destination afterward.

    Please try recreating a new application on the Google API Console

    end and see if it is working:

    – Check if the Google Drive API is enabled

    – From Credentials > OAuth consent screen, makse sure your top-level domain is added

    – When creating Credentials, please make sure Application Type as selected as Web application.

    Let us know how it went!

    Kind regards,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.