Snapshot Pro won't backup 2 of my subsites all of a sudden

Hi -
I have 12 sites and 2 of them will not run a backup on Snapshot. They have backed up before and then all the sites stopped but I realized that was because the Google drive needed to have more storage made available. After I did that I got all the sites to back up but now 2 refuse to run a backup since April 4th. The sites are the "PM Y3s (Not working)" and "AM 4/5s (not working)". Should I try and make brand new snapshots for these sites or am I doing something wrong? I've enabled support...

  • Adam Czajczyk

    Hello beau,

    I hope you're well today and thank you for your question.

    I accessed your site and checked both snapshots.

    Bot "not working" snapshots were recently performed on April 4th and according to logs successfully uploaded to their destinations. Next runs are scheduled accordingly for 20th and 23rd of June. It looks like they were indeed "skipped" though nothing in logs suggest why this may have happened.

    I then tried to run "AM 4/5s (not working)" snapshot manually but it took extremely long time and it seems like it hanged on one of media files. I wasn't able to continue and if this happens when it's run automatically it may indeed not leave any trace in snapshot logs.

    That said, I'd like to ask you to perform following test:

    1. add following lines to the "wp-config.php" file of your site:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true):
    define('WP_DEBUG_DISPLAY',false);

    These lines should be placed above the "/* That's all, stop editing..." line.

    2. Change "AM 4/5s (not working)" snapshot frequency to e.g. "Once hourly" or "Once daily" (but note more often that 1 hour because it takes long time to complete) and save settings

    3. Wait until the expected time passes by and then access your server via FTP (or cPanel "File Manager"):

    - go to /wp-content/ folder
    - download "debug.log" file
    - rename it to "debug.txt"
    - edit it to strip all data such as logins, passwords, db access credentials (if any)
    - attach it to your replay here.

    Best regards,
    Adam

  • Milan

    Hello beau

    Hope you are well today and thanks for asking us. :slight_smile:

    In your debug log I can see error of Maximum Execution time out exceeded. That could be the reason of issue here.

    So to increase Maximum Execution time limit for php, open your .htaccess file,(you'll fine it in your site's root folder) and add this line at beginning of file.

    php_value max_execution_time 60

    Save the file and test it again.

    Let me know how it goes. :slight_smile:
    Cheers,
    Milan

  • Beau

    Hi again,

    Well... whenever I paste that code (i've tried several different places in the htaccess wordpress root which is in a subdomain) the whole site shuts down with a error 500 message. Do you know what could be happening?

    I tried this as well

    <IfModule mod_php5.c>
    php_value max_execution_time 300
    </IfModule>

    It didn't give me a error 500 message but it didn't help the snapshot backup.

    Hmm?

  • Predrag Dubajic

    Hi Beau,

    Based on the debug file the execution time is still set to 30 seconds, can you check with your hosting provider to bump this up for you, it's possible that their server setup doesn't allow this change from the .htaccess file.

    As for the media add-on issue, it would be best to keep these questions in separate threads since the cause to these issue are most likely not related.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.