Snapshot produces Manifest Error

Trying to migrate sites from Sitemerce.com subdirectory multisites to brandmerce.com subdirectory multisites using snapshot and keep getting Manifest error. I've read all of the support entries related to this issue and tried everything and nothing works. I've given dashboard access to both multisites. Please help, I've been trying to migrate these sites for over a week with numerous support tickets and suggestions. I am really hoping snapshot is my answer. Thanks.

  • Rafael

    So here are the details of how I am using Snapshot to migrate my multisites and get the Manifest error.

    Snapshot Backup Creation from Sitemerce.com:
    On Sitemerce.com I use snapshot to create a new backup. I select all for files to archive: themes, plugins, uploads, etc, I also select all the tables/databases. I've exported to local and as well as drop box. Segment size 1000, memory 512M, I tried both options to download as a zipArchive and PclZip. I tried doing a full backup and a small backup to see if size was the issue.

    Snapshot import to brandmerce.com:
    To migrate the backup to brandmerce.com I imported the backup zip package entering the url from the dropbox backup which produced the manifest error, I then copied the zip to google drive and entered the url portion as indicated in the instructions and produced manifest error, I then ftp'd the local zip file from sitemerce.com uploads/snapshot folder to brandmerce.com uploads/snapshots folder to try to make it show up and just restore, but the file does not show up under all snapshots.

    I searched all forum entries related to snapshot-manifest error and tried all suggested fixes, and now really need you to dig into my multisites and try to fix the issue and try to make a migration. You have been given full access in both multisites. I hope you can help. Thanks.

  • Vinod Dalvi

    Hi @Rafael,

    Thank you for your detailed reply.

    I saw you posted in the following reply that you figured out how to fix the Manifest error.

    Ok. Lets close the ticket with Vinod since I figured out how to fix the Manifest error, and start a new ticket with you for new errors:

    https://premium.wpmudev.org/forums/topic/snapshot-manifest-error-continues-to-keep-occurring#post-682689

    If this is the case then it would be helpful for users in the community who are facing the same issue if you post here what was the issue and how you managed to fix it.

    Regards,
    Vinod Dalvi

  • Rafael

    Solution for anyone getting the "Manifest error" -this is how I solved it.

    The trick is to upload your snapshot to a new directory within your public-html then copy the local path in the import. See instructions below.

    I used this method to transfer one multisite 'A' to another multisite 'B'.

    1.Create your snapshot from multisite 'A':

    a. Go to Network admin/Dashboard/Snapshot
    b. Select Settings:
    - Folder Location: Leave blank to save to the default directory /home/wpsitename/public_html/wp-content/uploads/snapshot/
    - Database Segment Size: 1000
    - Memory Limit: 512M
    - Compression Library: ZipArchive
    c. Add New
    - Give it whatever name you'll use to find your backup
    - Files to archive (I selected common files)
    - Tables to archive ( I selected the include all database tables)
    - When to archive: Immediately
    - Where to save: local server
    - Create snapshot

    2. Use FTP or cPanel File Manager to download your newly created snapshot to your local computer, then upload the zip file to your destination multisite ('B'). The real trick here is to create a new folder to upload your snapshot to.

    a. In the destination multisite create a new folder public-html/snapshots
    b. upload the zip file to this folder

    3. Import your snapshot to your destination multisite

    a. Go to Network admin/snapshots/Import
    b. Enter the local url for the newly uploaded snapshot:
    public_html/snapshots
    c. Scan import button

    Success message with no more Manifest Error message.

    You should now see the newly imported snapshot in Snapshot/All snapshots.

    I hope this helps.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.