Snapshot Restore from One Multisite to Another is Failing.

Snapshot Restore from One Multisite to Another is Failing.

Can I get some remote assistance on what is going on?

  • James Morris
    • WordPress Enthusiast

    Hello Kenneth,

    I hope you are well today.

    When you say it does not work, would you please add more details? Did you get any error? What did you try and where did you stuck?

    There is a log file in /wp-content/uploads/snapshot/_logs/ folder where you can check if anything went wrong. Would you please share with us any logs you find there?

    Best regards,

    James Morris

  • Kenneth
    • Flash Drive

    I am having the exact same problem here with the wp options table:

    https://premium.wpmudev.org/forums/topic/snapshot-wont-restore-an-unknown-response-returned-from-snapshot-backup-attempt#post-1227569

    My client is already hounding me to go live, and this is causing me a great deal of stress. I need this subite I have installed on my Bluehost server to be restored a subsite on a new multisite I have running on a client's Dreamhost server. I am willing to provide any access to make this happen. I am worried judging by the above mentioned post that you are going to tell me you need a top-level admin to upload a table manually.

    Thanks in Advance

  • Ash
    • WordPress Hacker

    Hello Kenneth

    Sorry I need to know more details. Please let us know the following:

    1. Are you backing up a subsite from a multisite and restoring into another subsite in another multisite or single site?
    2. Is the table prefix same for wordpress installation?
    3. When you say not working, do you mean the restore fails or the restore is done but the site is not working?
    4. And please send us the log file /wp-content/uploads/snapshot/_logs/

    Please let us know about the above.

    Have a good day!

    Cheers
    Ash

  • Kenneth
    • Flash Drive

    Hi, Please read my previous post and look at the link I provided. When I mention I am having the exact same problem your previous customer, Gordon, described, I mean the exact same problem.

    1. I am backing up a sub-site from a multisite and restoring it to another sub-site in another multi-site
    2. The table prefix is not the same (if you are referring to the two different multi-site installations)
    3. This is relating to a restore that is failing. The restore never gets past the wp_options table.
    4.Attached are 3 log files in that folder you described

    If you could do anything in your power to expedite this, I would most certainly appreciate it. My client is worn out from waiting on me, and I need to have a resolution by this weekend.

  • Ash
    • WordPress Hacker

    Hello Kenneth

    Thanks for explaining in details. Number 2, yes, I was referring to two installations, it will help.

    The log file is not attached with your reply. Would you please email me the log files? Please email to contact@wpmudev.org with subject line "Attn-Ash" and a link of this thread so that I can track.

    We appreciate your patience, we will investigate and try to solve ASAP.

    Have a good day!

    Cheers
    Ash

  • Kenneth
    • Flash Drive

    Any luck? I cannot stress how important this is to resolve today. I've been up all night digging around in the wp_options table to figure out why this is holding me up. Also notice I cannot download the .ZIP file from the snapshot archives without getting a server error-- I have to download them manually through FTP. All files have 0755 permissions.

  • Kenneth
    • Flash Drive

    Ashok—

    I ended up having to manually upload and do a search/replace of the wp_contents table to the new multi-site. This took me a great deal of time to figure out, and I lost a client in the process. This is the exact same route I had to take as your other customer who reported the problem, Gordon.

    I will send you the materials you emailed to me so you can continue to diagnose the problem, but yes, this is definitely a problem that your team needs to get to the bottom of to ensure that agencies like myself are not put in peril of losing business at the eleventh hour during a migration.

  • Luís
    • Support

    Hi Kenneth ,

    Hope you're doing well today!

    My teammate Ashok sent you a reply via email at March 24th, have you checked it? Are you able to create a sandbox/staging version of your Multisite, an exact copy so we can make some debug without messing with your live version to avoid interfere with your users experience?

    If yes, please send the credentials via email as requested by Ashok.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.