Snapshot Restore Issue

Hi Support,

Having some problems restoring a snapshot, keep getting this error:

An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.

Any advise?

  • Eduardo Felix
    • WPMU DEV Initiate

    Hi Staq,

    I had the same problem and solved it this way:

    After 2 hours checking all settings: .htaccess, wp-config.php, root access on my server, I decided to create a new VM and transfer upload my ful backup.

    I use Digital Ocean, I created a new VM and uploaded the full backup generated by the snapshot and the file snapshot-installer.php, from there I was able to make my site work again in 3 hours.

    In total my site stayed for 6 hours offline

    Sorry for my English, I'm Brazilian ...

  • Predrag Dubajic
    • Support

    Hi Staq,

    I did couple of tests with your backup file, first one by trying to restore it to my local installation to make sure that the backup file is not corrupted or anything like that and that worked fine.

    I then created a new subsite on your site and first it failed at wp_options, then I excluded that but it stopped again at the wp_posts table.
    So it looks like this is something related to your server and we will need to investigate this further.

    Can you provide us with FTP or cPanel login details so we can dig deeper into this?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Eduardo Felix thanks for sharing your solution but this issue is related to regular snapshots so it looks like we're dealing with a different issue.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Staq,

    Thanks for sending those in, I did couple more tests but unfortunately there's nothing in debug log that would tell us what's going on.

    Could you try disabling all your other plugins and try to run the restore process after that?
    That will tell us if there's any conflict on that end and we can continue debugging it from there.

    Let us know how it goes.

    Best regards,
    Predrag

    • Staq
      • Flash Drive

      Hi Predrag,

      After some extensive testing over the last few days I'm at a loss on why this is happening;

      I've created a new VM (tx @Eduardo) deployed everything to there, still occurred, deployed a local mysql instance moved the DB from the AWS RDS instance, though it might be something on there, still occurred.

      Emptied the DB, reinstalled WP with multi site, only enabled three plugins; hummingbird(for separate issue), WPMUDEV dashboard and snapshot pro, created a new snapshot from the production site and imported, it's still failing on the sites options table, the table is only 15MB or so.

      I'm re-sending the some connection details as the setup has all changed

      Regards,

  • Predrag Dubajic
    • Support

    Hi Staq,

    I think I will need to ping our developers to investigate this further as there's little to none information on what's going on here.

    However I don't see your new email with the details, I'll answer on your first email so could you send the new credentials as a reply to that?

    Best regards,
    Predrag

  • Eduardo Felix
    • WPMU DEV Initiate

    Hi Staq,

    With me already happened error, when trying to restore fullbackup.

    unzip the fullbackup file, note that there are wordpress folders and various .sql files.

    Try to create a new database and import these .sql files, upload all wordpress files, open wp-config.php, and add the information from the new database.

    Access the database, the wp_options table, and rename the url of your site.

    If the problem is when restoring fullbackup, this way I did, but if the problem was when generating the fullbackup file, I do not see how to restore it with the corrupted file.

    Sorry for my english...

  • Ari
    • Recruit

    Hi Staq,

    Sorry to hear that you are in trouble with our plugin.

    Unfortunately I didn't find "ReaversSnapshot" to restore on your website. But I made more testing like: create backups & restore them. I completed them with no problem, all is well.

    Can you please check again is everything fine from your end?
    And let me know here if you have any trouble regarding this issue.

    Best Regards, Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.