[SNAPSHOT] Scheduled backup not running

There are a couple of cron jobs that do not appear to be running. It may be that the snapshot cron is also affected.

I can see an error on the cron panel.

There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:

cURL error 28: Operation timed out after 3001 milliseconds with 0 bytes received

When working with WP-Engine we temporarily deactivated the WP-Defender plugin and this error disappeared.

But the cron job still didn’t seem to run for Snapshot.

  • Adam Czajczyk
    • Support Gorilla

    Hello weshinckes

    I hope you’re well today and thank you for your question!

    I see that you have already installed WP Crontrol plugin and that’s great as it helps check cron events and schedules. I took a look there and it seems all the necessary schedules are actually set so that part is fine. However, there’s quite a lot of events scheduled (from WP itself and various plugins) and the more of them are there, the bigger the chance some might be skipped.

    I believe your site is currently using the default WP Cron, is that right? Could you please contact WP Engine’s live support again and ask them if they could enable their alternate real cron for you for the site?

    According to this doc, they should be able to do this for you and that cron, as far as I understand it, should be a real server cron – so if that’s it, it would be a very reliable solution.

    If they can do this, please after they do clear all caches on your site and save Snapshot schedule again and then wait until the time the backup should be created to see if it works.

    Let’s see if that helps. If not, let me know, please, and I’ll continue investigating it to find a solution.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello weshinckes

    Thank you for response!

    I checked the site again and it seems that the Cron is now running fine indeed. I can see that Snapshot related events are also triggered as expected.

    However, you’re right about backups not being run. I tried to run “Full Backup” snapshot manually and it completed fine and quite fast actually. But when I changed the schedule so I could see if it’s triggered, it didn’t seem to be run automatically.

    I’ll need to dig a bit deeper then but it seems that SFTP access that you shared during the chat is not working, unfortunately – connections are rejected due to “current directory set to .” (the dot means usually the parent-most folder in the folder structure).

    Could you please double-check these credentials and provide me with working ones?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Adam Czajczyk

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    I’ll then do some more “in-depth” testing and include our developers in the case if necessary.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello weshinckes

    Thank you, that worked and I was able to access FTP.

    The weird thing that I found out is that the snapshot internal logs are created and rotated and it seems that the backup process… is actually fired up. But there’s no further clue what happens, what might be causing it to break and so on. I checked what I could think of but I must say I don’t see any reason for this – especially that manually started snapshot runs perfectly fine.

    That said, I’ve passed all the information to our developers (along with access credentials so if you could please keep those active and unchanged for now) and asked them to help me investigate and solve this.

    Please keep an eye on this ticket and we’ll be updating you as soon as we get to know more from them.

    Kind regards,

    Adam

  • Tho Bui
    • Staff

    Hi weshinckes,

    I am glad you were able to resolve it on your end. If you have any doubts or need any help further, feel free to reply in the thread here and we would be very happy to help you with it. Also If you do not require any help regarding this, you can also mark this as resolved.

    Cheers,

    Tho Bui

  • weshinckes
    • Flash Drive

    Hi Tho,

    That’s not quite the case.

    The Managed Backups now appear to be running fine. Whether that is due to an update or some other reason I cannot tell you.

    The normal daily local backups to the server are still not running though. It would be good if you could take a look.

    Many thanks,

    Wes

  • Tho Bui
    • Staff

    Hello weshinckes,

    Apologies for the delay, I saw you excluded one table and the normal daily local backup is working fine now. Also before I tried to add an MU to your site to test the backup, it’s mu-plugins/snapshot-sync-backup.php file. It’s an old version and its conflict with the new version of Snapshot. In that case, can you help me to remove it, because I can’t access the FTP now?

    Kind Regards,

    Tho Bui

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.