Snapshot Setup-Forbidden Backup

I just installed Snapshot on my multisite, following the WPMUDev instructions to do so, but when I try to send a back up to Dropbox, I get the error message:

Forbidden

You don't have permission to access /wp-admin/admin-ajax.php on this server.

How do I move past this to get Snapshot up and running properly?

  • Timothy Bowers

    Hey there.

    Forbidden is a 403 error, it usually happens when something on the server is preventing that connection.

    Does your htaccess prevent access in any way?

    Check to see if it's the default WP ones, or if there is something custom there.

    You're also going to want to check with your host about the server setup.

    I tested and it seems ok for me. So to check you added the API details, get a backup going and at that point this occurs?

    Could you let me know exactly where this occurs, screenshots too if you think it might help. :slight_smile:

    Take care

  • Dharmendra

    Hello @AmyJoy,

    I hope you are well today and thanks for asking the question.

    Sounds like a file permissions issue. Do you have root access? (Ask your hosting if you don't know)

    Could you let me know what your file permissions are on the files and specifically that actual file please?

    You can check the file permissions on the folder in question by visiting the directory via FTP, right clicking on the folder and checking them there. (With most FTP programs this is how it works)

    Could you please try another Snapshot Destinations and let me know if it works?

    Please advise.

    Have a great day! :slight_smile:

  • Timothy Bowers

    Hey again.

    You said the root file permissions, if this is a cPanel account they wouldn't be owned by the root, they would be owned by the account user even if that's you. You might want to check that.

    Can you please also check the server error logs for the forbidden/403 message?

    If you have mod_sec enabled on the server then just for testing could you please disable that and give it another shot?

    If that's the issue there are some easy solutions like disabling it for for the wp-admin folder, or just for the file.

    Let me know.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.