Snapshot starts creating backups automatically without stopping

Hi, i don't know why but snapshot started creating backups automatically, i have reviewed all settings and it seems ok, i have deactivated and activated again but didn't fixed anything.

It happens in any blog that i want to backup, it was working normally with version WP 4.2.4, i have upgraded to 4.3 now snapshot starts creating backups automatically one after another without stopping, the only way to stop it creating backups is by deactivating the plugin.

I also tried to disable plugins and i didn't found any messing with snapshot.

Thank you

  • Adam Czajczyk

    Hello @pedro_resina,

    I hope you're well today and thank you for your question!

    It seems that the issue is related to the WP Cron rather than a plugin itself. WP Cron is a tool used by WordPress to run tasks periodically. Snapshot is using this engine to fire up the backup procedure.

    There are some known cases of WP Cron "going crazy". This may be caused be number of reasons but it's worth noting that WP Cron is depending strictly on a front-end traffic of the site. It may not be precise in case of extremely low/high traffic and also caching plugins (and caching engines running on servers' side) may cause some conflicts here.

    That being said, I'd suggest trying the following solution:

    1. Review all your existing snapshots' settings and make sure that the "Backup Interval" option is set to a reasonable period such as e.g. "once hourly" or less often.

    2. Switch your WP from using WP Cron to a real server Cron. This can be achieved by

    - adding this line to the wp-config.php file:

    define('DISABLE_WP_CRON', true);

    - if you have shell access (SSH) to your server, you will want to log in and issue this command (replacing http://example.org with an URL of your WP install):

    */5 * * * * curl -I http://example.org/wp-cron.php?doing_wp_cron

    - if you're using cPanel to manage your server, please go to "Cron jobs" tool inside the "Advanced" tab, then use the settings table to set Cron to run every 5 or 10 minutes and use

    curl -I http://example.org/wp-cron.php?doing_wp_cron

    as a command.

    This should switch your WP site from using WP Cron to real server's Cron which is reliable and should fix the issue.

    Let me know if it helped please!

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.