Snapshot stops on plugin file

Hi,

I am having trouble when creating a snapshot. It stops at 82% on the file " plugin".
Please see screen copy.
How could I fix this issue ?

Thanks for your help
Cédric

  • Adam Czajczyk

    Hello Cedric,

    I hope you're well today and thank you for your question!

    Does it always stop at the very same point? The error on a screenshot suggests that there has been some communication glitch related to the OVH CDN so most likely some connection times out.

    I have accessed your site and tried to run snapshot and I could see that error. I noticed also some "503 gateway errrors" in a browser console related to ajax calls lasting a bit longer. I suppose then that OVH CDN may have some limits set on connection timeout.

    Is it possible to temporarily disable that CDN for the site and see if that changes anything or is it "fixed to the hosting" and you are not able to disable it? If so, do you think you could get in touch with your host and ask them if there are any limits and/or if they could check server logs to see if they could change related settings for you?

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Cédric,

    Can you give a few more tries on this but instead of creating full snapshot try one without plugins and then one with plugins only.

    If one without the plugins stops at the themes then the timeout is most likely the cause here, and if Plugins on their own fail then we want to look further into this and find which plugin is causing it.

    Let us know how it goes.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Cédric,

    Thanks for granting access, I have tried performing multiple tests on your site, plugins only work, everything except plugins also work, everything including plugins fails, however managed backup that contains everything also works fine, I'm quite stumped here...

    I even tried full backup with the plugins but excluding them all in exclude field but that also failed. :slight_frown:

    Can you enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Try creating new full snapshot and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Also, could you get in touch with your server provider and check if there are any server logs that could tell us what's going on?

    Best regards,
    Predrag

  • Cedric

    Hi Pedrag,

    Thanks for your help. I have ran a full snapshot. Please see attached the debug log.

    We also have access to the logs from our web hosting, please see below what is its content :

    [Fri Jan 13 00:10:20 2017] [error] [client 213.186.33.151] [host unchef.fr] client denied by server configuration: /homez.239/yachtcheki/www5/wp-includes/index.php, referer: http://unchef.fr/wp-includes/
    [Fri Jan 13 00:10:20 2017] [error] [client 213.186.33.151] [host unchef.fr] client denied by server configuration: /homez.239/yachtcheki/www5/wp-content/uploads/.htaccess, referer: http://unchef.fr/wp-content/uploads/.htaccess
    [Fri Jan 13 00:10:20 2017] [error] [client 213.186.33.151] [host unchef.fr] client denied by server configuration: /homez.239/yachtcheki/www5/wp-content/plugins/wp-defender/vault/sample.bak, referer: http://unchef.fr/wp-content/plugins/wp-defender/vault/sample.bak
    [Fri Jan 13 00:10:20 2017] [error] [client 213.186.33.151] [host unchef.fr] client denied by server configuration: /homez.239/yachtcheki/www5/wp-includes/wp-db.php, referer: http://unchef.fr/wp-includes/wp-db.php
    [Fri Jan 13 00:10:20 2017] [error] [client 213.186.33.151] [host unchef.fr] client denied by server configuration: /homez.239/yachtcheki/www5/wp-content/index.php, referer: http://unchef.fr/wp-content/index.php
    [Fri Jan 13 00:10:20 2017] [error] [client 213.186.33.151] [host unchef.fr] client denied by server configuration: /homez.239/yachtcheki/www5/wp-content/uploads/defender-access-test.php, referer: http://unchef.fr/wp-content/uploads/defender-access-test.php
    Please let know if you need access to those logs.

    Best regards,

    Cédric

  • Dimitris

    Hello Cédric,

    hope you're doing good and don't mind chiming in here! :slight_smile:

    The debug.log file you kindly shared is showing to us the following error message:WordPress database error Lost connection to MySQL server
    It seems that there's a memory issue here. :thinking:

    Could you please try to increase memory limit as described here?
    https://premium.wpmudev.org/blog/increase-memory-limit/
    I can see that memory_limit is set to 512M, you may want to further raise it but first you should advise your hosting provider about the actual memory limits you have.

    It looks like mysql is crashing while running the query. If there is not enough memory for mysql to run it will crash. Inspecting your MySQL settings here
    /wp-admin/admin.php?page=wpmudev-support&view=system#tab-mysql
    I can see the following:

    key_buffer_size	2 GB
    max_allowed_packet	16 MB
    max_connections	300
    query_cache_limit	262144
    query_cache_size	300 MB

    Could you please lower those buffer sizes a bit to see if this resolves the issue?
    Again, your hosting provider support channel can help you set those if you don't have such access level. FYI here's my settings in a test environment that I use:

    key_buffer_size	64 MB
    max_allowed_packet	128 MB
    max_connections	150
    query_cache_limit	2 MB
    query_cache_size	64 MB

    If all these comes down to nothing, please provide us the complete server logs. You can upload the file in a service like Dropbox or Google Drive and post the shareable link here.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.