Snapshot Timeout error

I have tried several times to run a snapshot and I am getting a timeout error. If I'm excluding plugins folder fomr the backup, everything works fine.
No errors in debug.log

  • Adam Czajczyk

    Hello logins

    I have checked your site and noticed that at some point during the plugin backup internal ajax calls time out after 30 seconds, even though it looked like max_execution_time was set to 60 seconds.

    First, it turned out that custom max_execution_time setting added to "wp-config.php" file doesn't take any effect on your server settings. I tested changing it via custom "php.ini" file but that didn't work either so I assume that your server's got some limitations put on that.

    However, the fact it times out suggest one (or some of them) of the files inside the /plugins folder might be quite heavy and with current server performance it takes a bit too long for the Snapshot scripts to process it. Therefore I made some changes in wp-config.php file to tweak site's resource (WordPress allowed memory) usage and to change the way Snapshot creates a backup. After that I was able to successfully complete a "one off" local backup. You can see it on the site: "WPMU A Test 2" snapshot. So, that's a good sign so far.

    Then, I have created another backup (Scheduled Remote Test) and set it to be run daily and uploaded to remote destination. Let's leave it like that for now, and please keep an eye on it. It should be run daily at 4.40am (according to WP time zone settings).

    Since backup itself might take some time to complete and then upload might take even longer, please wait until that time tomorrow passes by and give it additional couple of hours and then check if it was completed and successfully uploaded and let me know here about it.

    If it still doesn't work, I'll then investigate it further.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.