Snapshot times out uploading large zip

Hi,

Snapshot times out when uploading a full site backup (~500MB). With the media folder removed (~20MB) it's fine. the log shows cUrl error 56. So the question is how do we increase the timeout to cater for large sites and is there likely to be an option for multipart uploads to S3 to get around this?

Regards,

Andrew

  • Vaughan

    hiya

    you would need to increase this by editing your servers php.ini

    this isn't always the same on all servers, you may want to consult with your host.

    you will need to increase memory_limit to 256M

    and increase max_execution_time to around 600 possibly.

    sometimes you can do this by creating a php.ini file and uploading it to your public_html folser.

    inside it place the following

    memory_limit = 256M
    max_execution_time = 600

    in some shared hosting environments, access to the PHP memory limit setting is restricted. If you cannot make the change yourself, please ask your hosting provider to adjust it for you, or look for a new host that allows more flexibility.

    For some hosts renaming php.ini to php5.ini may be necessary.

    Some hosting services require the following line in .htaccess to enable a php.ini file.
    suPHP_ConfigPath ~/public_html

    hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.