Snapshot Vs Auto Blog - WP Cron!!!

I've hard time to run both Snapshot and Auto Blog at same time.
I've disabled WP Cron and setup cron job at cpannel.
This way Auto blog (and many other things like post scheduling etc) working fine but Snapshot showing following error:
Your site has disabled the WordPress Cron scheduler (WP_CRON). When scheduling an archive to be created it may not run. Check your wp-config.php for the DISABLE_WP_CRON define. If found either remove it or set the value to "false".

If I enable WP cron then Auto blog stop working.

Pls give me better way to work on both.

  • Kasia Swiderska
    • Support nomad

    Hello mannuforall,

    Yes, Snapshot will show this error because it cannot check if you are using real cron job - when you go to the settings you will see similar error, but with additional information:

    WP_CRON - Disabled. Check your wp-config.php for the DISABLE_WP_CRON define. When scheduling snapshots to run you will need to call the wp-cron.php file from an external source

    Even if you disable WP cron you are still able to set scheduled snapshots and they will be handled by real cron.
    Are schedules snapshots not creating on your site now?

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello mannuforall,

    I've created test snapshot and it is working - also I clicked 'run now' on your other snapshots and they are creating (when you click run now it will only show in column "Interval" that are they running now)

    Can you show me how did you created real cron job? You can link to tutorial you used to create it.

    kind regards,
    Kasia

  • Rupok
    • Support Ninja

    Hi mannuforall, hope you had a wonderful day.

    Thanks for the reference link you provided. Can you please provide us the exact cron command you are using? That will help us in regenerating the issue.

    And it seems like Support Access is expired. Can you please revoke and grant us permission again so we continue our investigation and try to fix the issue faster?

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello mannuforall,

    It looks like there is problem with sending backup to destination. Could you do test and add another destination - local server to backup that run daily and see if this time it will go though with creating snapshot?
    If that will fail please enable debug mode in your WordPress. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see contents of the debug.log file - so please paste it to the text file and attach to post or upload to service like Dropbox and paste here link.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi mannuforall,

    Hope you are doing good today. :slight_smile:

    I have gone through your website, and I created a test snapshot for a 15 mins schedule, and it seems to work fine in your local server. The snapshot what I created consist of only database. Could you please try again, and check whether it works. Please do keep the debug log on, and check whether you are able to create a new snapshot. I have deleted these snapshot, because I didn't wanna flood your local server with 15 mins backup. Please check the screenshots:

    But when your select full files, backup doesn't seem to work, since the database snapshot seems to work, could you please take backups by splitting your files, and check which section is causing a problem. For eg: only select Themes and check whether it's working, then try with plugins selected , and so on.

    Please try and check where your snapshot fails, that may be the file that is causing the problem. I hope this helps. Please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi mannuforall,

    Hope you are doing good today. :slight_smile:

    Sorry to know that you are still having issues with the plugin, could you please send us your credentials so that we can have a closer look?

    You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi mannuforall,

    Hope you are doing good today. :slight_smile:

    I checked your website, but it seems like the username you provided doesn't have the required permission to use Snapshot plugin, and the plugin is hidden in the dashboard. I cannot find any way to use the plugin.

    Please check, and make the required changes. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi mannuforall,

    Hope you are doing good today. :slight_smile:

    I was extensively testing your website, and I can confirm that the Cron job is working fine with backing up files in regular intervals.

    I did a manual backup, and I encountered a 524 error, which is related to having low memory. Going through your server settings, I could find that the memory were set to 128M, with a max_execution_time 45.

    I have made the following changes by adding these values in your php.ini file, this have improved the backup time. Please do note only defining the WP_MAX_MEMORY won't increase the memory, it only allocates the available memory.

    upload_max_filesize = 192M
    post_max_size = 256M
    memory_limit = 1024M
    max_execution_time = 180

    Your Cron backups are not working because, max_execution_time is being set to 45, not sure where it's set, most probably a plugin is resetting the value 180 to 45. Since it's a live website, I didn't perform a plugin conflict test. Would recommend you to disable all the plugins, and check whether the max_execution_value is 180 again, you can see the value defined under Snapshot > Settings > Server Info

    Some files, and your database wp_dfr_xtrack(200MB), needs more time to process, since the max_exection_time is 45, the scheduled backups are failing.

    Would recommend to perform a backup, with all plugins disabled, and check whether it works. You can then rule out the plugin causing this conflict.

    I hope this helps. Please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello mannuforall,

    In that case can you contact your hosting provider and ask if you can use php.ini to change value of max_execution_time and if not (or there is some other setting that is overriding this value) can they increase that for you?
    If this will not help I will flag Second Line Support guys.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi mannuforall,

    Hope you are doing good today. :slight_smile:

    I have been able to track the files causing the problem, it happens to be mediafolders, and one of your database table wp_dfr_xtrack which is almost 187 MB in size.

    Excluding these files, I'm able to perform a scheduled Snapshot without any issue. With the media folders it may have to be the files being too large, or being corrupted. Would suggest you to give a look at /wp-content/uploads folders, and try to exclude such files causing this problem. Other option would be to backup the media folders manually via FTP.

    I have done a test scheduled snapshot without the mentioned files, and it's working. I have set a Snapshot(wpmudev-test-20) to run daily once, and it should work. Would recommend you to check these files.

    I hope this helps. Please let us know if you still have any issues. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • mannuforall
    • Design Lord, Child of Thor

    Hi
    As per your suggestion to excluding database table ‘wp_dfr_xtrack’ which was very big in size.
    To do this I've deleted the Datafeedr plugin (this plugin responsible for wp_dfr_xtrack).
    But this table still showing in database.
    How to completely delete a plugin with its all data and database tables?

  • Nithin
    • Support Wizard

    Hi mannuforall,

    Hope you are doing good today. :slight_smile:

    Did you delete the plugin using FTP? This can happen if the files are removed through FTP, most of the plugins support deletion of database, if it's removed through the WordPress dashboard, ie deactivate the plugin, and click the delete option in the Plugins menu. If you have already made this far, and still have plugin database. The only option would be to manually remove these by going through the phpmyadmin in your cpanel, and check for tables which have wp_dfr as it's prefix.

    Or you could make use of a plugin to clean up your database: https://wordpress.org/plugins/wp-clean-up-optimizer/

    Would highly recommend, that you take a backup, before making such changes, I hope this helps. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi mannuforall,

    I removed it from WordPress dashboard by deactivating and deleting but it left in database.Is there an easy and safe way to find out all such useless database tables etc?

    Thanks for pointing that out, most plugins does make sure that the database are deleted when it's removed from the database, I guess that option is not available in this plugin. Other than that, I'm afraid there isn't any easy option to find out such useless tables, you'll have to make use of a database clean up plugins.
    https://wordpress.org/plugins/wp-clean-up-optimizer/
    https://wordpress.org/plugins/wp-optimize/

    You can find all the default database tables for WordPress, listed here: https://codex.wordpress.org/Database_Description

    I hope this helps. Please let us know if you still need any further assistance. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.