Snapshot with files not working on HTTPS site

Using Snapshot 2.2, and the WordPress HTTPS plugin, snapshots which include files do not work.

It just gets stuck on 'Creating archive 0%'.

As well as this, clicking Settings causes a server error.

I've tried this on several different sites.

  • Paul
    • The Green Incsub

    @shaun_robinson,

    Greetings again. I'm a little confused. I thought we did covered this issue in a previous thread??

    https://premium.wpmudev.org/forums/topic/https-snapshot-problem#post-318448

    Since your initial thread there has been some others posting on a similar issue. Still I'm not able to reproduce this under any of my own environments running Snapshot and the HTTPS plugins.

    https://premium.wpmudev.org/forums/topic/snapshot-plugin-not-working#post-343480

    So again I ask if it is possible that I can get login access to one of your sites experiencing this interesting issue so maybe I can debug things?

    As well as this, clicking Settings causes a server error.

    If not them please provide some more details per your above comment. As that is really not enough information to start an investigation.

  • Shaun
    • The Incredible Code Injector

    Hi, no it's a separate issue - the other thread I was having trouble logging in. Now it is working OK but a backup with 'files' included fails to run, and clicking the Settings tab has a server error.

    How can I send you login details privately?

  • Paul
    • The Green Incsub

    @shaun_robinson,

    Yes, please send login info to paul [at] incsub.com

    So was doing some searches. Seems outside of Snapshot and HTTP plugins this is somewhat of a common issue. Here is one of many threads on that same error
    http://wordpress.org/support/topic/ouput-buffering-error

    One solution I've seem mentioned increasing your memory in the wp-config.php. Can I ask that you double the memory allocated to WordPress in your wp-config.php. Just a note that no matter how much memory you have set in your php.ini, WordPress will set the limit to 40M for WordPress single and 64M for Multisite.

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    So in you wp-config.php try setting your memory to 128 like
    define('WP_MEMORY_LIMIT', '128M');

    If that doesn't work then please send the login info.

  • Paul
    • The Green Incsub

    Reply from Shaun via private email. Wanted to post here for information others might find as a possible solution:

    I'm not sure if this is a problem with HTTPS after all, like you said it may just be a memory issue. I increased the memory to 128M and this made the Settings page load again, but the files still do not back up.

    It works on a test site I set up, but not on my live site. I think this is because the test site had just 22MB of files but the live site has hundreds of MB. I can't give you access to the live site as it has sensitive eCommerce information in it.

    I've tried the 2 different zip methods to no avail. Does it just not work on large zips? Is there a log anywhere so I can see what is going wrong? Right now it just looks like it's going to back up (I click run now, it says Now: creative archive 0%), but then going back to it later nothing has happened.

    Please help! Thanks.

  • Shaun
    • The Incredible Code Injector

    OK so removing Media from the snapshot makes it work, I guess it was running out of memory due to a lot of media files. This could be a bit clearer, and a solution is needed to make it work with large media files, but glad that is sorted for now - I'll just remove the media from the backup. Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.