SnapshotPro not working on new hosting

Hi,
I'm having an issue here, even GoDaddy can't figure it out. I used the plugin in the past and it worked well but now, I got an error message telling me to increase the limit ... And it take all the resource on the server and I can't try again.

1st call : I've been asked to desactivate the plugin, I did but something keep running in the background, I got disconnected and had to call again

2nd : They deleted the plugin but it didn't change anything .... 3rd call : Been forwarded to an expert who suggest to reset the server :slight_frown: Which I did but I got the same error on my 4th attempt : What's going on ?

I downloaded the plugin yesterday, so it's up-to date
I setup a new Wordpress
I increase the limit on wp-config.php
I try install the plugin and it broke the server again

Even hear of something similar ?
What am I suppose to do now ?
Thanks

  • Steven
    • The Incredible Code Injector

    wp-admin/admin.php?page=snapshots_import_panel

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@domain.com to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log.

  • Steven
    • The Incredible Code Injector

    Oh ... I was downloading the WPMU Dev Dashboard plugin, to give you an access ... When I notice the download of the plugin failed yesterday !!!!

    So I downloaded again ... And now have this error message :

    PHP max_execution_time : 900s

    Attempting to download remote file : http://domain.com/files/snapshot-1446828684-151106-165124-055705c6.zip

    Processing archive: snapshot-1446828684-151106-165124-055705c6.zip (109.53M)
    Error: Manifest data not found in archive.

    Snapshot import complete

    What is that "PHP max_execution_time : 900s"
    And how can I fix this ?
    Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello Steven,

    I hope you're well today and thank you for your question!

    Before I go any further, let me please say a word of advice: do not ever edit any core WP files, please. This isn't a secure way of fixing things and may lead to many unexpected issues, not to mention the fact that most likely such changes will either be lost upon WordPress update or cause performance issues (worst case scenario: total break of the site that would be difficult or impossible to track).

    Thanks for understanding :slight_smile:

    As for the issue. The warning clearly states that the site is consuming most of the resources of your server. Unfortunately, it do not indicate type of resources except memory usage. I assume that the limit is set to 1024M (screenshot shows this). Assuming that's a "clean install" I'd first try the following steps:

    1) make sure that all possible changes made to WP core files are reverted; you will want to work on default, up to date WP install;

    2) Disable all plugins; If this removes an error we know it's Snapshot related; in this case switch Snapshot back on and...

    3) Switch to default Twenty Fifteen theme

    4) Make sure that there are these lines in your wp-config.php file (that's the only configuration file of WP that's meant to be edited sometimes!):

    define('WP_MEMORY_LIMIT', '256M');
    define('WP_MAX_MEMORY_LIMIT','512M');

    These lines must to be located anywhere after "<?php" tag and before the "/* That's all..." line.

    Then, if this still doesn't help, let me know here please giving as detailed description of what happened (e.g. other errors or warnings) as possible.

    Best regards,
    Adam

    • Steven
      • The Incredible Code Injector

      Hi Adam, actually, it was not, I just added it here :

      *
       * @package WordPress
       */
      
      // ** MySQL settings - You can get this info from your web host ** //
      
      define('WP_MEMORY_LIMIT', '256M');
      define('WP_MAX_MEMORY_LIMIT','512M');
      
      /** The name of the database for WordPress */
      define('DB_NAME', 'i196543_wp1');

      As I said above, looks like I may have an issue with a failed transfer so I'm downloading the zip again & will do another attempt ... Let's hope it will work : will keep you inform, thanks

      • Steven
        • The Incredible Code Injector

        No .... Same error : PHP max_execution_time : 900s

        I called the server again, Made me installed a php.ini and he confirmed everything is fine on their end ... and I should call the DEV of the plugin

        So I just installed the DEV plugin and granted you Access

        It's for the .CO domain

        Can you please tell me what's wrong, thank you

        • Adam Czajczyk
          • Support Gorilla

          Hello Steven!

          In my previous post I was referring to the initial error that you've described in your original question. I've been able to access your site and it seems to be working fine at the moment. Moving on to "max_execution_time" then.

          This is a PHP settings that's limiting maximum time any PHP script is allowed to be running for. Therefore, in case the script is not able to complete the task withing 900 seconds it will just terminate and this may lead to some unexpected issues.

          That said I'd like to ask you to clarify this a bit. Does this error come up while you're trying to restore backup from snapshot archive file or when you're trying to import (if yes, then what way?) snapshot archive?

          Also, were you able to create a snapshot archive successfully on this particular site?

          Please advise!

          It would be also great if you could keep the support access open for me until we solve the issue!

          Best regards,
          Adam

          • Steven
            • The Incredible Code Injector

            Hi Adam,
            All I try do do is copy my .com on a .co

            Got the error while trying to import
            I use snapshot on the .com, who created a zip file
            I downloaded that zip and upload it elsewhere for an easy access such as
            http://domain.com/backup.zip

            On the new site.co, I just installed SnapPro,
            give it the url to import and got the error !

            I failed at 8 attempts so far and it's getting annoying now :slight_smile:
            Thanks for any tip you may have

          • Adam Czajczyk
            • Support Gorilla

            Hello Steven!

            Thanks for explanation. Could you please try another way? Instead of giving Snapshot an URL of an archive to be restored, please upload this archive into the "/wp-content/uploads/snapshots/" folder of the site you'd like to import it into?

            Then, please go to your dashboard's "Snapshots" -> "Import" page and click on "Scan/Import Snapshots" leaving "URL or local path to Snapshot Archive" field empty.

            This should scan for archive and that archive should then appear on "Snapshots" -> "All Snapshots" page, therefore allowing you to restore backup.

            Let me know if it helped, please!

            Best regards,
            Adam

          • Steven
            • The Incredible Code Injector

            Well ... I just noticed my new zip file upload (176MB) had a "pending" status ... and it created a 2nd one (4MB) that have the status "complete" ... Perhaps, this is the trouble !?!

            It's been a week now .. Please help :slight_smile:
            Thanks, later

          • Adam Czajczyk
            • Support Gorilla

            Hello Steven!

            Thank you for information!

            I've been redirected to a 404 page with no result

            This actually bothers me a log as with snapshot archive uploaded directly to the target server the plugin shouldn't try to look for it anywhere else, therefore shouldn't redirect.

            Well ... I just noticed my new zip file upload (176MB) had a "pending" status ... and it created a 2nd one (4MB) that have the status "complete" ... Perhaps, this is the trouble !?!

            It's a clue, yes, but still shouldn't work like this.

            I tried to access your site again but it seems that the support access has already expired. However, I think it's time to dig a bit deeper so would yo mind me accessing your site directly? Could you please send in:

            Subject: "Attn: Adam Czajczyk"

            - your site's WordPress admin login URL
            - admin login and password (may be a temporary account)
            - FTP credentials (hostname, username, password, port number if needed)
            - phpMyAdmin login URL
            - any other relevant URLs and information
            - link back to this thread

            Please use our contact form here https://premium.wpmudev.org/contact/.
            Select "I have a different question" from the drop-down list.

            Please be sure to make a full backup of your entire site first!

            Best regards,
            Adam

          • Adam Czajczyk
            • Support Gorilla

            Hello Steven!

            I'm sorry for the delay here. I've somehow missed your previous response here which is of course unacceptable and I apologize for that!

            I got your message, however access data you sent me (to v2... site) doesn't work for me and I'm not able to login. Also, either an FTP access or access to the cPanel (or other server management tool, that depends on what's being used on your hosting account) may be very useful here as otherwise I'm not able to access files such as wp-config.php, nor am I able to run some test php scripts or check file permissions etc.

            That said, would it be possible for you to supplement that data for me (please send a message the same way you did recently)? This would help much!

            Thank you!
            Best regards,
            Adam

          • Adam Czajczyk
            • Support Gorilla

            Hello Steven!

            Thank you for your e-mail. I've been able to access your server this time.

            I've removed that 4M-size snapshot from your site and re-uploaded full archive to your server, then imported it. It seems that the Snapshot itself has been successfully imported.

            I've checked PHP settings on your site and it looks like now file size, script execution time and memory limits are now set high enough for snapshot to complete. That said, I've started "restore" procedure.

            I've also enabled WordPress debugging with output being written to /wp-content/debug.log file just in case snapshot wouldn't complete. Therefore I should be able to find out why is that so, hopefully.

            I will need to take another look in a few hours since with that big snapshot it may take a bit of time so I'll update this thread today again with more information.

            Best regards,
            Adam

          • Steven
            • The Incredible Code Injector

            Well, I'm sorry to say that I'll be forced to cancel my subscription and look for an alternative way to backup if this issue is not resolved within the next 72hrs.

            I'm loosing business here, lost credibility and start to affect my relation with someone so I gotta do something. Nothing personal, just business.

            Support access granted again.
            Thanks for doing something today !

    • Adam Czajczyk
      • Support Gorilla

      Hello Faydra,

      I hope you're well today!

      First of all, let me please say that I really appreciate and highly value your help on this and other threads. It's really great to have such an active, sharing and helpful member in our community. You're doing a great job for us all!

      That said, please don't get me wrong but we do not advise editing core WordPress files due to the number of reasons (some of them I have already explained in my previous post). Please note, that not only pretty much every WP based site is different but also these sites work in different environments and their admins/developers present very different skills. Therefore, I fully understand that you have done this many times and everything went well each time. In fact, I have also made changes to WP core files on some of my own sites in the past. These were my own sites though, I never do this anymore and I never advise this to anyone :slight_smile:

      I sincerely believe that I you get my point. Thank you for understanding and keep up the great work! Have a great day and thanks again for all your help!

      Cheers,
      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.