Snapshots are downloading as 0MB files

Hi all,

I have a need to get into a backup from last week (or the week before), and when I click to download any Snapshot zip, I'm getting a 0KB file which unzips into a 0KB .cpgz.

I'm using Snapshot 2.4.2.7.

Thoughts?

Thanks,
Adam

  • Adam
    • The Incredible Code Injector

    Also: maybe not coincidentally, Snapshot was crashing the entire site (www.selfeservetoys.com) by duplicating WP-specific code in our .htaccess file. I found this out after aggressively plugin-conflict testing. I've just reinstalled it and will let you know.

    Edit: I couldn't even get through reinstallation before the site crashed. Here's what my .htaccess file looks like after Snapshot has been installed for a few seconds:

    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  • Tyler Postle
    • CGO

    Hey Adam,

    Hope you're doing well today!

    I just tested this out on my own installation and created a snapshot without any issues. .htaccess seems to be fine too. Do you mind go into your /wp-content/uploads/snapshots/_log and taking a look at one of your recent log files. If you could post the contents here that would help :slight_smile:

    As you probably already realized, the .htaccess definitely shouldn't be looking like that, you can delete all but one of those code blocks if you like. Or just delete them all and re-save your permalinks to create a new .htaccess.

    Look forward to your reply here Adam!

    Cheers,
    Tyler

    • Adam
      • The Incredible Code Injector

      Thanks, @Tyler Postle. I'm not sure what caused the issue, but it's definitely shaken my faith in Snapshot on this site.

      I ended up deleting the extra code in the .htaccess file more than 30 times, searching for the culprit. I didn't realize regenerating Permalinks would accomplish that too—good to know—though the extra code would debilitate the entire site, so I couldn't get in there to do it. :slight_smile:

      I'd also like to be able to get you the logs, but I'm unable to, for the same reasons. Also, after the debacle, I deleted Snapshot altogether, and I think I risk debilitating the site again by reinstalling it.

      If you have another idea I'd be happy to hear it. Alternatively, I'd be happy to grant Support Access, if that would help.

      Thanks,
      Adam

    • Adam
      • The Incredible Code Injector

      With everything deactivated Snapshot was causing problems. Those two are okay for you to deactivate, though, if it aids in diagnosing. If you could make a backup beforehand—assuming there isn't already one from last night—that'd be grand. Thanks!

  • aristath
    • Recruit

    Hello again @Adam,

    This is what I did:
    * I de-activated backupbuddy and brutebrotect, and I activated snapshot.
    * From Snapshot => Settings, I set the compression to use ZipArchive instead of PclZip (it's on the bottom of the settings page)
    * I created a new snapshot and backup up the database.

    The backup ran fine and the resulting file was perfectly healthy.

    I then tried activating the backupbuddy and bruteprotect plugins and tried creating a new snapshot.
    While it ran, I got an error message (see attached screenshot).
    Now I am completely unable to access the dashboard because I'm getting that message.

    Can you please delete the snapshot plugin and test if that fixes your issue?
    I don't have your FTP credentials to do it myself.....

    The problem is that the above 2 plugins take up A LOT of resources from the server and that prevents anything complex from running.

    Without bruteprotect everything is working fine.

    Let me know if that fixes your issue!

    Cheers,
    Ari.

    • Adam
      • The Incredible Code Injector

      Hi @aristath,

      I believe I sent FTP credentials to another support staffer for this site earlier this week. I'm deleting Snapshot now and have fixed the .htaccess file; it's back to normal now. For the record, that is the same message I received when the site went down a few weeks ago, and the .htaccess was overrun with duplicates of the WP code. I think it's clear there's a conflict between Snapshot and BruteProtect.

      Is that something you're willing to take on debugging? I'm afraid if forced to choose we're going to have to pick BruteProtect, and continue to use a(n outdated) copy of Backup Buddy.

      Thanks!
      Adam

  • Hoang Ngo
    • Code Slayer

    Hi @Adam,

    I hope you are well today.

    I will need to check the config in the backend to reproduce the bug, could you enable support staff login in WPMU DEV dashboard > support > support access > grant access, please :slight_smile:

    Thanks!!!

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Hi @Adam,

    I hope you are well today and I'm sorry for the issue.

    Actually I still not do anything to your site yet, so the reason make your site down, maybe another reason, I think some cron or auto task have run, and cause some issue.

    Let me check it now and be back to your shortly.

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Hi @Adam,

    Hmm, the token has expired :slight_frown:. I'm sorry for this inconvenience, can you please send the access info to me via.

    - Mark to my attention - ATTN: Hoang Ngo
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    This will be last longer, and still same security :slight_smile:

    I'm sorry for this inconvenience, and many thanks for your patience.

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Hi @Adam,

    I hope you are well today and many thanks for your information.

    I see that you have disabled the SnapShot plugin, also, it's look like the ftp is from another site, as I see the plugins from ftp and on the site is not sync.

    I try to reproduce the bug again on many environments, but it still not appear, so I think this is something only happen in rare case.

    What I want to do is place some tracking codes on your site, it will help me to debug the bug issue better, so the right ftp is very needed.

    Thanks!!!

    Best regards,
    Hoang Ngo

    • Adam
      • The Incredible Code Injector

      Hm, that's strange. Could be the hosting company gave me an FTP account for you for the wrong folder—they don't have cPanel, so I'm reliant on humans to get things done.

      Thanks for the alternate solution! That sounds like the safest plan.

      best,
      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.